TTCDownloadLibrary: Download Library API

TTCDownloadLibrary D-TTCSW-G-20-005
  • Main Page
  • Data Structures
  • Files
Download Library API
Version
1.0.1
Date
03.06.2015

This document describes the API of the download library.

Generated on Mon Jun 8 2015 14:39:05 for TTCDownloadLibrary by doxygen 1.8.6


TTCDownloadLibrary: Data Structures

  • Files
  • Data Structures
  • Data Structure Index
  • Data Fields
Data Structures
Here are the data structures with brief descriptions:
o C auth_block_t | Authentication block structure
o C bl_apdb_ | APDB structure
o C bl_t_can_id_ | CAN ID structure
o C bl_t_date_ | Date structure
o C bldb_t | BLDB structure
o C DLDAPDB_t | APDB
o C DLDBLDB_t | BLDB
o C DLDCANIdentifier_t | CAN Identifier
o C DLDCPUInfo_t | CPU Information
o C DLDDriverInfo_t | Driver Information
o C DLDFIDB_t | FIDB
o C DLDIconInfo_t | Icon Information
o C DLDIPAddress_t | IP Address
o C DLDMemoryInfo_t | Memory Information
o C DLDNodeInfo_t | Node Information
o C DLDTargetInfo_t | Target Information
\ C FIDB_t | FIDB structure


TTCDownloadLibrary: auth_block_t Struct Reference

  • Data Fields
Data Fields
auth_block_t Struct Reference

Authentication block structure. More...

#include <AuthenticationBlock.h>

Data Fields

ubyte4 Flags
ubyte4 StartAddress
ubyte4 CodeSectionStart
ubyte4 CodeSectionSize
ubyte4 CodeSectionCRC
ubyte1 Reserved [16]
ubyte4 CRC

Detailed Description

Authentication block structure.

Data structure for authenticating bootloader and FPGA IP descriptor blocks.

Field Documentation

ubyte4 auth_block_t::CodeSectionCRC

CRC-32 calculated over the entire code section.

ubyte4 auth_block_t::CodeSectionSize

Code section size in bytes.

ubyte4 auth_block_t::CodeSectionStart

Code section start address.

ubyte4 auth_block_t::CRC

CRC-32 calculated over the entire descriptor block.

ubyte4 auth_block_t::Flags

Flags (see Authentication block flags).

ubyte1 auth_block_t::Reserved[16]

Reserved for future use.

ubyte4 auth_block_t::StartAddress

Start address of the protected assembly.

The documentation for this struct was generated from the following file:
  • AuthenticationBlock.h


TTCDownloadLibrary: bl_apdb_ Struct Reference

  • Data Fields
Data Fields
bl_apdb_ Struct Reference

APDB structure. More...

#include <APDB.h>

Collaboration diagram for bl_apdb_:
[legend]

Data Fields

ubyte4 APDBVersion
BL_T_DATE FlashDate
BL_T_DATE BuildDate
ubyte4 NodeType
ubyte4 CRCStartAddress
ubyte4 CodeSize
ubyte4 LegacyApplicationCRC
ubyte4 ApplicationCRC
ubyte4 NodeNumber
ubyte4 CRCSeed
ubyte4 Flags
ubyte4 Hook1
ubyte4 Hook2
ubyte4 Hook3
ubyte4 MainAddress
BL_T_CAN_ID CANDownloadID
BL_T_CAN_ID CANUploadID
ubyte4 LegacyHeaderCRC
ubyte4 ApplicationVersion
ubyte4 CANBaudrate
ubyte4 CANChannel
ubyte4 Password
ubyte4 MagicSeed
ubyte1 | TargetIPAddress [4]
ubyte1 | SubnetMask [4]
ubyte1 | DLMulticastIPAddress [4]
ubyte4 DebugKey
ubyte4 ABRDTimeout
ubyte1 ManufacturerID
ubyte1 ApplicationID
ubyte2 Reserved
ubyte4 HeaderCRC

Detailed Description

APDB structure.

Data structure for accessing the Application Descriptor Block.

Field Documentation

ubyte4 bl_apdb_::ABRDTimeout

The timeout for automatic CAN baud rate detection in seconds (HY-TTC 30X family only).

ubyte4 bl_apdb_::APDBVersion

The APDB version (see APDB_VERSION):

  • bit 0-7 ... minor number
  • bit 8-15 ... major number
ubyte4 bl_apdb_::ApplicationCRC

CRC-32 value calculated over the application or if a CRC table is used, CRC-32 value calculated over the CRC table (automatically provided by the TTC-Downloader).

ubyte1 bl_apdb_::ApplicationID

The application identifier (must be provided by the application).

ubyte4 bl_apdb_::ApplicationVersion

The application version (must be provided by the application):

  • bit 0-15 ... revision number
  • bit 16-23 ... minor number
  • bit 24-31 ... major number
BL_T_DATE bl_apdb_::BuildDate

The application's build date (must be provided by the application).

ubyte4 bl_apdb_::CANBaudrate

Baud rate in kbit/s used for CAN communication (must be provided by the application).

ubyte4 bl_apdb_::CANChannel

The channel used for CAN communication (must be provided by the application).

BL_T_CAN_ID bl_apdb_::CANDownloadID

The CAN identifier used for download direction (TTC-Downloader -> target, must be provided by the application).

BL_T_CAN_ID bl_apdb_::CANUploadID

The CAN identifier used for upload direction (target -> TTC-Downloader, must be provided by the application).

ubyte4 bl_apdb_::CodeSize

Code size in bytes (used for CRC calculation) or if a CRC table is used, number of CRC table entries (automatically provided by the TTC-Downloader).

ubyte4 bl_apdb_::CRCSeed

Seed for application CRC calculation (automatically provided by the TTC-Downloader).

ubyte4 bl_apdb_::CRCStartAddress

Start address for CRC calculation or if a CRC table is used, start address of the CRC table (automatically provided by the TTC-Downloader).

ubyte4 bl_apdb_::DebugKey

Debug key for booting the device in debug mode (HY-TTC 500 family only).

ubyte1 bl_apdb_::DLMulticastIPAddress[4]

Multicast IP address of the TTC-Downloader (most significant byte first, HY-TTC 500 family only).

ubyte4 bl_apdb_::Flags

Predefined application flags can be specified here. Following flags can be specified:

  • bit 0 ... Auto-BaudrateDetectionEnable (HY-TTC 30X family only):
    • 0 = disable automatic baud rate detection
    • 1 = enable automatic baud rate detection
BL_T_DATE bl_apdb_::FlashDate

The date when the application has been flashed (automatically provided by the TTC-Downloader).

ubyte4 bl_apdb_::HeaderCRC

The CRC value calculated over the whole APDB (automatically provided by the TTC-Downloader).

ubyte4 bl_apdb_::Hook1

Custom hook 1.

ubyte4 bl_apdb_::Hook2

Custom hook 2.

ubyte4 bl_apdb_::Hook3

Custom hook 3.

ubyte4 bl_apdb_::LegacyApplicationCRC

Legacy application CRC for flash checker (automatically provided by the TTC-Downloader).

ubyte4 bl_apdb_::LegacyHeaderCRC

Legacy header CRC for flash checker (automatically provided by the TTC-Downloader).

ubyte4 bl_apdb_::MagicSeed

Seed for CRC calculation with the MCHK HW module (automatically provided by the TTC-Downloader).

ubyte4 bl_apdb_::MainAddress

The application's start address. Note that the bootloader uses this address to start the application after reset/power-up. See #APPL_START defined in file ptypes_apdb.h (must be provided by the application).

ubyte1 bl_apdb_::ManufacturerID

The manufacturer identifier (must be provided by the application).

ubyte4 bl_apdb_::NodeNumber

The unique node number used to identify nodes of a CODESYS application. Note that only values from 0 to 127 are allowed (must be provided by the application).

ubyte4 bl_apdb_::NodeType

The hardware type the application is built for (automatically provided by the TTC-Downloader).

ubyte4 bl_apdb_::Password

The password hash for memory access. Set this field to 0 or 0xFFFFFFFF to disable password protection. Note that it is highly recommended to set a password upon application download with the TTC-Downloader.

ubyte2 bl_apdb_::Reserved

Reserved for future use. Shall be set to 0.

ubyte1 bl_apdb_::SubnetMask[4]

Subnet mask for Ethernet download (most significant byte first, HY-TTC 500 family only).

ubyte1 bl_apdb_::TargetIPAddress[4]

Target IP address for Ethernet download (most significant byte first, HY-TTC 500 family only).

The documentation for this struct was generated from the following file:
  • APDB.h


TTCDownloadLibrary: bl_t_can_id_ Struct Reference

  • Data Fields
Data Fields
bl_t_can_id_ Struct Reference

CAN ID structure. More...

#include <APDB.h>

Data Fields

ubyte4 extended
ubyte4 ID

Detailed Description

CAN ID structure.

Field Documentation

ubyte4 bl_t_can_id_::extended

Type of CAN identifier to be used. Valid values are:

  • 0 ... standard CAN identifier is used
  • 1 ... extended CAN identifier is used
ubyte4 bl_t_can_id_::ID

The CAN identifier (LSB must start at bit 0):

  • bit 0-10 ... if standard CAN identifier is used
  • bit 0-28 ... if extended CAN identifier is used
The documentation for this struct was generated from the following file:
  • APDB.h


TTCDownloadLibrary: bl_t_date_ Struct Reference

  • Data Fields
Data Fields
bl_t_date_ Struct Reference

Date structure. More...

#include <APDB.h>

Data Fields

ubyte4 date

Detailed Description

Date structure.

Data structure for saving dates like flash or build date.

Field Documentation

ubyte4 bl_t_date_::date

Date in format YYYY/MM/DD hh:mm. The fields are defined as followed:

  • bit 0-11 ... year
  • bit 12-15 ... month
  • bit 16-20 ... day
  • bit 21-25 ... hour
  • bit 26-31 ... minute
The documentation for this struct was generated from the following file:
  • APDB.h


TTCDownloadLibrary: bldb_t Struct Reference

  • Data Fields
Data Fields
bldb_t Struct Reference

BLDB structure. More...

#include <BLDB.h>

Collaboration diagram for bldb_t:
[legend]

Data Fields

ubyte4 NodeType
ubyte4 NodeVariant
ubyte4 NodeVersion
ubyte4 BootloaderVersion
BL_T_CAN_ID CANDownloadID
BL_T_CAN_ID CANUploadID
ubyte4 CANBaudrate
ubyte4 CANChannel
ubyte4 BootloaderVersionPatchlevel
ubyte1 | TargetIPAddress [4]
ubyte1 | SubnetMask [4]
ubyte1 | DLMulticastIPAddress [4]
ubyte1 | Reserved [24]
ubyte4 Flags
ubyte4 BLDBVersion
AUTH_BLOCK_T authentication_block

Detailed Description

BLDB structure.

Data structure for accessing the Bootloader Descriptor Block.

Field Documentation

AUTH_BLOCK_T bldb_t::authentication_block

The authentication block.

ubyte4 bldb_t::BLDBVersion

The BLDB version:

  • bit 0-7 ... minor number
  • bit 8-15 ... major number
ubyte4 bldb_t::BootloaderVersion

The bootloader version:

  • bit 0-7 ... minor number
  • bit 8-15 ... major number
ubyte4 bldb_t::BootloaderVersionPatchlevel

Patchlevel of the bootloader version.

ubyte4 bldb_t::CANBaudrate

Baud rate in kbit/s used for CAN communication.

ubyte4 bldb_t::CANChannel

The channel used for CAN communication.

BL_T_CAN_ID bldb_t::CANDownloadID

The CAN identifier used for download direction (TTC-Downloader -> target).

BL_T_CAN_ID bldb_t::CANUploadID

The CAN identifier used for upload direction (target -> TTC-Downloader).

ubyte1 bldb_t::DLMulticastIPAddress[4]

Multicast IP address of the TTC-Downloader (mostsignificant byte first).

ubyte4 bldb_t::Flags

Flags (see BLDB flags).

ubyte4 bldb_t::NodeType

The node's hardware type.

ubyte4 bldb_t::NodeVariant

The node's hardware variant.

ubyte4 bldb_t::NodeVersion

The node's hardware revision

  • bit 0-15 ... minor number
  • bit 15-31 ... major number
ubyte1 bldb_t::Reserved[24]

Reserved for future use.

ubyte1 bldb_t::SubnetMask[4]

Subnet mask for Ethernet download (most significant byte first).

ubyte1 bldb_t::TargetIPAddress[4]

Target IP address for Ethernet download (most significant byte first).

The documentation for this struct was generated from the following file:
  • BLDB.h


TTCDownloadLibrary: DLDAPDB_t Struct Reference

  • Data Fields
Data Fields
DLDAPDB_t Struct Reference

APDB. More...

#include <Download.hpp>

Collaboration diagram for DLDAPDB_t:
[legend]

Data Fields

BL_APDB fields
bool | application_valid
bool | block_valid

Detailed Description

APDB.

Stores the APDB (and some useful information) of a certain node.

Field Documentation

bool DLDAPDB_t::application_valid

Indicates whether or not the application checksum is valid.

bool DLDAPDB_t::block_valid

Indicates whether or not the APDB's header checksum is valid.

BL_APDB DLDAPDB_t::fields

The APDB fields.

The documentation for this struct was generated from the following file:
  • Download.hpp


TTCDownloadLibrary: DLDBLDB_t Struct Reference

  • Data Fields
Data Fields
DLDBLDB_t Struct Reference

BLDB. More...

#include <Download.hpp>

Collaboration diagram for DLDBLDB_t:
[legend]

Data Fields

BLDB_T fields
bool | bootloader_valid
bool | block_valid

Detailed Description

BLDB.

Stores the BLDB (and some useful information) of a certain node.

Field Documentation

bool DLDBLDB_t::block_valid

Indicates whether or not the BLDB's header checksum is. valid.

bool DLDBLDB_t::bootloader_valid

Indicates whether or not the application checksum is valid

BLDB_T DLDBLDB_t::fields

The BLDB fields.

The documentation for this struct was generated from the following file:
  • Download.hpp


TTCDownloadLibrary: DLDCANIdentifier_t Struct Reference

  • Data Fields
Data Fields
DLDCANIdentifier_t Struct Reference

CAN Identifier. More...

#include <Download.hpp>

Data Fields

uint32_t | id
uint8_t | format

Detailed Description

CAN Identifier.

Stores an identifier used for CAN communication.

Field Documentation

uint8_t DLDCANIdentifier_t::format

CAN identifier format (see CAN Identifier Format).

uint32_t DLDCANIdentifier_t::id

CAN identifier (11-bit or 29-bit).

The documentation for this struct was generated from the following file:
  • Download.hpp


TTCDownloadLibrary: DLDCPUInfo_t Struct Reference

  • Data Fields
Data Fields
DLDCPUInfo_t Struct Reference

CPU Information. More...

#include <Download.hpp>

Data Fields

char | name [DLD_MAX_STRING_LENGTH]
uint8_t | endian
uint8_t | data_width

Detailed Description

CPU Information.

Stores useful information of a certain CPU.

Field Documentation

uint8_t DLDCPUInfo_t::data_width

The CPU's data width in bits.

uint8_t DLDCPUInfo_t::endian

The CPU's endian (see Endian).

char DLDCPUInfo_t::name[DLD_MAX_STRING_LENGTH]

The name of the CPU.

The documentation for this struct was generated from the following file:
  • Download.hpp


TTCDownloadLibrary: DLDDriverInfo_t Struct Reference

  • Data Fields
Data Fields
DLDDriverInfo_t Struct Reference

Driver Information. More...

#include <Download.hpp>

Data Fields

uint8_t | type
uint8_t | index
void * | custom_data

Detailed Description

Driver Information.

Stores useful information of a certain driver.

Field Documentation

void* DLDDriverInfo_t::custom_data

Pointer to the driver's custom data.

uint8_t DLDDriverInfo_t::index

The driver's index.

uint8_t DLDDriverInfo_t::type

The driver's type (see Driver Type).

The documentation for this struct was generated from the following file:
  • Download.hpp


TTCDownloadLibrary: DLDFIDB_t Struct Reference

  • Data Fields
Data Fields
DLDFIDB_t Struct Reference

FIDB. More...

#include <Download.hpp>

Collaboration diagram for DLDFIDB_t:
[legend]

Data Fields

FIDB_T fields
bool | fpga_ip_core_valid
bool | block_valid

Detailed Description

FIDB.

Stores the FIDB (and some useful information) of a certain node.

Field Documentation

bool DLDFIDB_t::block_valid

Indicates whether or not the FIDB's header checksum is valid.

FIDB_T DLDFIDB_t::fields

The FIDB fields.

bool DLDFIDB_t::fpga_ip_core_valid

Indicates whether or not the application checksum is valid.

The documentation for this struct was generated from the following file:
  • Download.hpp


TTCDownloadLibrary: DLDIconInfo_t Struct Reference

  • Data Fields
Data Fields
DLDIconInfo_t Struct Reference

Icon Information. More...

#include <Download.hpp>

Data Fields

char | path [DLD_MAX_STRING_LENGTH]
char | url [DLD_MAX_STRING_LENGTH]
char | tooltip [DLD_MAX_STRING_LENGTH]

Detailed Description

Icon Information.

Stores additional information of a certain target ECU.

Field Documentation

char DLDIconInfo_t::path[DLD_MAX_STRING_LENGTH]

Path to the target ECU's icon.

char DLDIconInfo_t::tooltip[DLD_MAX_STRING_LENGTH]

THE target's tooltip text.

char DLDIconInfo_t::url[DLD_MAX_STRING_LENGTH]

The target's associated URL.

The documentation for this struct was generated from the following file:
  • Download.hpp


TTCDownloadLibrary: DLDIPAddress_t Struct Reference

  • Data Fields
Data Fields
DLDIPAddress_t Struct Reference

IP Address. More...

#include <Download.hpp>

Data Fields

uint8_t | bytes [4]
uint8_t | format

Detailed Description

IP Address.

Stores an IPv4 address.

Field Documentation

uint8_t DLDIPAddress_t::bytes[4]

IPv4 address.

uint8_t DLDIPAddress_t::format

The byte array's endian (see Endian).

The documentation for this struct was generated from the following file:
  • Download.hpp


TTCDownloadLibrary: DLDMemoryInfo_t Struct Reference

  • Data Fields
Data Fields
DLDMemoryInfo_t Struct Reference

Memory Information. More...

#include <Download.hpp>

Data Fields

uint32_t | address
uint32_t | size

Detailed Description

Memory Information.

Stores memory information of a certain item (see Item).

Field Documentation

uint32_t DLDMemoryInfo_t::address

The item's start address.

uint32_t DLDMemoryInfo_t::size

The item's size in bytes.

The documentation for this struct was generated from the following file:
  • Download.hpp


TTCDownloadLibrary: DLDNodeInfo_t Struct Reference

  • Data Fields
Data Fields
DLDNodeInfo_t Struct Reference

Node Information. More...

#include <Download.hpp>

Collaboration diagram for DLDNodeInfo_t:
[legend]

Data Fields

char | serial_number [16]
char | target_name [DLD_MAX_STRING_LENGTH]
DLDDriverInfo_t driver
uint32_t | target_id
uint32_t | bootloader_version
uint8_t | node_number

Detailed Description

Node Information.

Stores useful information of a certain node.

Field Documentation

uint32_t DLDNodeInfo_t::bootloader_version

The node's bootloader version: bit 0-7 ... minor number bit 8-15 ... major number

DLDDriverInfo_t DLDNodeInfo_t::driver

Information about the driver the node is connected through.

uint8_t DLDNodeInfo_t::node_number

The node's address.

char DLDNodeInfo_t::serial_number[16]

The node's serial number.

uint32_t DLDNodeInfo_t::target_id

The target's identifier.

char DLDNodeInfo_t::target_name[DLD_MAX_STRING_LENGTH]

The node's target name.

The documentation for this struct was generated from the following file:
  • Download.hpp


TTCDownloadLibrary: DLDTargetInfo_t Struct Reference

  • Data Fields
Data Fields
DLDTargetInfo_t Struct Reference

Target Information. More...

#include <Download.hpp>

Collaboration diagram for DLDTargetInfo_t:
[legend]

Data Fields

DLDCPUInfo_t cpu
DLDIconInfo_t icon
char | target_name [DLD_MAX_STRING_LENGTH]
uint16_t | can_baudrates [14]
uint8_t | can_channels [8]
char | file_extension [8]
uint32_t | target_id
uint32_t | bootloader_version
uint8_t | no_applications
uint8_t | no_apdbs
uint8_t | no_config_data_regions
uint8_t | no_can_baudrates
uint8_t | no_can_channels
uint8_t | no_int_flash_regions
uint8_t | no_int_eeprom_regions
uint8_t | no_ext_flash_regions
uint8_t | no_ext_eeprom_regions

Detailed Description

Target Information.

Stores useful information of a certain target.

Field Documentation

uint32_t DLDTargetInfo_t::bootloader_version

The target's bootloader version: bit 0-7 ... minor number bit 8-15 ... major number

uint16_t DLDTargetInfo_t::can_baudrates[14]

Holds the supported CAN baudrates.

uint8_t DLDTargetInfo_t::can_channels[8]

Holds the supported CAN channels.

DLDCPUInfo_t DLDTargetInfo_t::cpu

The target's CPU.

char DLDTargetInfo_t::file_extension[8]

The target's default file extension.

DLDIconInfo_t DLDTargetInfo_t::icon

The target's icon.

uint8_t DLDTargetInfo_t::no_apdbs

Holds the number of APDBs.

uint8_t DLDTargetInfo_t::no_applications

Holds the number of application regions.

uint8_t DLDTargetInfo_t::no_can_baudrates

Holds the number of supported CAN baudrates.

uint8_t DLDTargetInfo_t::no_can_channels

Holds the number of supported CAN channels.

uint8_t DLDTargetInfo_t::no_config_data_regions

Holds the number of configuration data regions.

uint8_t DLDTargetInfo_t::no_ext_eeprom_regions

Holds the number of external EEPROM regions.

uint8_t DLDTargetInfo_t::no_ext_flash_regions

Holds the number of external flash regions.

uint8_t DLDTargetInfo_t::no_int_eeprom_regions

Holds the number of internal EEPROM regions.

uint8_t DLDTargetInfo_t::no_int_flash_regions

Holds the number of internal flash regions.

uint32_t DLDTargetInfo_t::target_id

The target's identifier.

char DLDTargetInfo_t::target_name[DLD_MAX_STRING_LENGTH]

The target's name.

The documentation for this struct was generated from the following file:
  • Download.hpp


TTCDownloadLibrary: FIDB_t Struct Reference

  • Data Fields
Data Fields
FIDB_t Struct Reference

FIDB structure. More...

#include <FIDB.h>

Collaboration diagram for FIDB_t:
[legend]

Data Fields

ubyte4 FIDBVersion
ubyte4 NodeType
ubyte4 NodeVariant
ubyte4 NodeVersion
ubyte4 FPGAVersion
ubyte2 FPGARevision0
ubyte2 FPGARevision1
ubyte2 FPGARevision2
ubyte1 Reserved [62]
AUTH_BLOCK_T authentication_block

Detailed Description

FIDB structure.

Data structure for accessing the Bootloader Descriptor Block.

Field Documentation

AUTH_BLOCK_T FIDB_t::authentication_block

The authentication block.

ubyte4 FIDB_t::FIDBVersion

The FIDB version:

  • bit 0-7 ... minor number
  • bit 8-15 ... major number
ubyte2 FIDB_t::FPGARevision0

FPGA revision number 0.

ubyte2 FIDB_t::FPGARevision1

FPGA revision number 1.

ubyte2 FIDB_t::FPGARevision2

FPGA revision number 2.

ubyte4 FIDB_t::FPGAVersion

The FPGA IP version:

  • bit 0- 8 ... patch level
  • bit 8-15 ... minor number
  • bit 16-31 ... major number
ubyte4 FIDB_t::NodeType

The node's hardware type.

ubyte4 FIDB_t::NodeVariant

The node's hardware variant.

ubyte4 FIDB_t::NodeVersion

The node's hardware revision

  • bit 0-15 ... minor number
  • bit 15-31 ... major number
ubyte1 FIDB_t::Reserved[62]

Reserved for future use.

The documentation for this struct was generated from the following file:
  • FIDB.h


TTCDownloadLibrary: Data Structure Index

  • Data Fields
Data Structure Index
A | B | D | F
D
DLDCPUInfo_t DLDMemoryInfo_t
a
bl_t_can_id_
DLDDriverInfo_t DLDNodeInfo_t bl_t_date_
DLDAPDB_t DLDFIDB_t DLDTargetInfo_t auth_block_t bldb_t
DLDBLDB_t DLDIconInfo_t
F
b
DLDCANIdentifier_t DLDIPAddress_t
FIDB_t bl_apdb_
A | B | D | F


TTCDownloadLibrary: Data Fields

  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- a -

  • ABRDTimeout : bl_apdb_
  • address : DLDMemoryInfo_t
  • APDBVersion : bl_apdb_
  • application_valid : DLDAPDB_t
  • ApplicationCRC : bl_apdb_
  • ApplicationID : bl_apdb_
  • ApplicationVersion : bl_apdb_
  • authentication_block : bldb_t , FIDB_t

- b -

  • BLDBVersion : bldb_t
  • block_valid : DLDAPDB_t , DLDBLDB_t , DLDFIDB_t
  • bootloader_valid : DLDBLDB_t
  • bootloader_version : DLDNodeInfo_t , DLDTargetInfo_t
  • BootloaderVersion : bldb_t
  • BootloaderVersionPatchlevel : bldb_t
  • BuildDate : bl_apdb_
  • bytes : DLDIPAddress_t

- c -

  • can_baudrates : DLDTargetInfo_t
  • can_channels : DLDTargetInfo_t
  • CANBaudrate : bl_apdb_ , bldb_t
  • CANChannel : bl_apdb_ , bldb_t
  • CANDownloadID : bl_apdb_ , bldb_t
  • CANUploadID : bl_apdb_ , bldb_t
  • CodeSectionCRC : auth_block_t
  • CodeSectionSize : auth_block_t
  • CodeSectionStart : auth_block_t
  • CodeSize : bl_apdb_
  • cpu : DLDTargetInfo_t
  • CRC : auth_block_t
  • CRCSeed : bl_apdb_
  • CRCStartAddress : bl_apdb_
  • custom_data : DLDDriverInfo_t

- d -

  • data_width : DLDCPUInfo_t
  • date : bl_t_date_
  • DebugKey : bl_apdb_
  • DLMulticastIPAddress : bl_apdb_ , bldb_t
  • driver : DLDNodeInfo_t

- e -

  • endian : DLDCPUInfo_t
  • extended : bl_t_can_id_

- f -

  • FIDBVersion : FIDB_t
  • fields : DLDAPDB_t , DLDBLDB_t , DLDFIDB_t
  • file_extension : DLDTargetInfo_t
  • Flags : auth_block_t , bl_apdb_ , bldb_t
  • FlashDate : bl_apdb_
  • format : DLDCANIdentifier_t , DLDIPAddress_t
  • fpga_ip_core_valid : DLDFIDB_t
  • FPGARevision0 : FIDB_t
  • FPGARevision1 : FIDB_t
  • FPGARevision2 : FIDB_t
  • FPGAVersion : FIDB_t

- h -

  • HeaderCRC : bl_apdb_
  • Hook1 : bl_apdb_
  • Hook2 : bl_apdb_
  • Hook3 : bl_apdb_

- i -

  • icon : DLDTargetInfo_t
  • ID : bl_t_can_id_
  • id : DLDCANIdentifier_t
  • index : DLDDriverInfo_t

- l -

  • LegacyApplicationCRC : bl_apdb_
  • LegacyHeaderCRC : bl_apdb_

- m -

  • MagicSeed : bl_apdb_
  • MainAddress : bl_apdb_
  • ManufacturerID : bl_apdb_

- n -

  • name : DLDCPUInfo_t
  • no_apdbs : DLDTargetInfo_t
  • no_applications : DLDTargetInfo_t
  • no_can_baudrates : DLDTargetInfo_t
  • no_can_channels : DLDTargetInfo_t
  • no_config_data_regions : DLDTargetInfo_t
  • no_ext_eeprom_regions : DLDTargetInfo_t
  • no_ext_flash_regions : DLDTargetInfo_t
  • no_int_eeprom_regions : DLDTargetInfo_t
  • no_int_flash_regions : DLDTargetInfo_t
  • node_number : DLDNodeInfo_t
  • NodeNumber : bl_apdb_
  • NodeType : bl_apdb_ , bldb_t , FIDB_t
  • NodeVariant : bldb_t , FIDB_t
  • NodeVersion : bldb_t , FIDB_t

- p -

  • Password : bl_apdb_
  • path : DLDIconInfo_t

- r -

  • Reserved : auth_block_t , bl_apdb_ , bldb_t , FIDB_t

- s -

  • serial_number : DLDNodeInfo_t
  • size : DLDMemoryInfo_t
  • StartAddress : auth_block_t
  • SubnetMask : bl_apdb_ , bldb_t

- t -

  • target_id : DLDNodeInfo_t , DLDTargetInfo_t
  • target_name : DLDNodeInfo_t , DLDTargetInfo_t
  • TargetIPAddress : bl_apdb_ , bldb_t
  • tooltip : DLDIconInfo_t
  • type : DLDDriverInfo_t

- u -

  • url : DLDIconInfo_t


TTCDownloadLibrary: Data Fields - Variables

  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u

- a -

  • ABRDTimeout : bl_apdb_
  • address : DLDMemoryInfo_t
  • APDBVersion : bl_apdb_
  • application_valid : DLDAPDB_t
  • ApplicationCRC : bl_apdb_
  • ApplicationID : bl_apdb_
  • ApplicationVersion : bl_apdb_
  • authentication_block : bldb_t , FIDB_t

- b -

  • BLDBVersion : bldb_t
  • block_valid : DLDAPDB_t , DLDBLDB_t , DLDFIDB_t
  • bootloader_valid : DLDBLDB_t
  • bootloader_version : DLDNodeInfo_t , DLDTargetInfo_t
  • BootloaderVersion : bldb_t
  • BootloaderVersionPatchlevel : bldb_t
  • BuildDate : bl_apdb_
  • bytes : DLDIPAddress_t

- c -

  • can_baudrates : DLDTargetInfo_t
  • can_channels : DLDTargetInfo_t
  • CANBaudrate : bl_apdb_ , bldb_t
  • CANChannel : bl_apdb_ , bldb_t
  • CANDownloadID : bl_apdb_ , bldb_t
  • CANUploadID : bl_apdb_ , bldb_t
  • CodeSectionCRC : auth_block_t
  • CodeSectionSize : auth_block_t
  • CodeSectionStart : auth_block_t
  • CodeSize : bl_apdb_
  • cpu : DLDTargetInfo_t
  • CRC : auth_block_t
  • CRCSeed : bl_apdb_
  • CRCStartAddress : bl_apdb_
  • custom_data : DLDDriverInfo_t

- d -

  • data_width : DLDCPUInfo_t
  • date : bl_t_date_
  • DebugKey : bl_apdb_
  • DLMulticastIPAddress : bl_apdb_ , bldb_t
  • driver : DLDNodeInfo_t

- e -

  • endian : DLDCPUInfo_t
  • extended : bl_t_can_id_

- f -

  • FIDBVersion : FIDB_t
  • fields : DLDAPDB_t , DLDBLDB_t , DLDFIDB_t
  • file_extension : DLDTargetInfo_t
  • Flags : auth_block_t , bl_apdb_ , bldb_t
  • FlashDate : bl_apdb_
  • format : DLDCANIdentifier_t , DLDIPAddress_t
  • fpga_ip_core_valid : DLDFIDB_t
  • FPGARevision0 : FIDB_t
  • FPGARevision1 : FIDB_t
  • FPGARevision2 : FIDB_t
  • FPGAVersion : FIDB_t

- h -

  • HeaderCRC : bl_apdb_
  • Hook1 : bl_apdb_
  • Hook2 : bl_apdb_
  • Hook3 : bl_apdb_

- i -

  • icon : DLDTargetInfo_t
  • ID : bl_t_can_id_
  • id : DLDCANIdentifier_t
  • index : DLDDriverInfo_t

- l -

  • LegacyApplicationCRC : bl_apdb_
  • LegacyHeaderCRC : bl_apdb_

- m -

  • MagicSeed : bl_apdb_
  • MainAddress : bl_apdb_
  • ManufacturerID : bl_apdb_

- n -

  • name : DLDCPUInfo_t
  • no_apdbs : DLDTargetInfo_t
  • no_applications : DLDTargetInfo_t
  • no_can_baudrates : DLDTargetInfo_t
  • no_can_channels : DLDTargetInfo_t
  • no_config_data_regions : DLDTargetInfo_t
  • no_ext_eeprom_regions : DLDTargetInfo_t
  • no_ext_flash_regions : DLDTargetInfo_t
  • no_int_eeprom_regions : DLDTargetInfo_t
  • no_int_flash_regions : DLDTargetInfo_t
  • node_number : DLDNodeInfo_t
  • NodeNumber : bl_apdb_
  • NodeType : bl_apdb_ , bldb_t , FIDB_t
  • NodeVariant : bldb_t , FIDB_t
  • NodeVersion : bldb_t , FIDB_t

- p -

  • Password : bl_apdb_
  • path : DLDIconInfo_t

- r -

  • Reserved : auth_block_t , bl_apdb_ , bldb_t , FIDB_t

- s -

  • serial_number : DLDNodeInfo_t
  • size : DLDMemoryInfo_t
  • StartAddress : auth_block_t
  • SubnetMask : bl_apdb_ , bldb_t

- t -

  • target_id : DLDNodeInfo_t , DLDTargetInfo_t
  • target_name : DLDNodeInfo_t , DLDTargetInfo_t
  • TargetIPAddress : bl_apdb_ , bldb_t
  • tooltip : DLDIconInfo_t
  • type : DLDDriverInfo_t

- u -

  • url : DLDIconInfo_t


TTCDownloadLibrary: File List

  • File List
  • Globals
File List
Here is a list of all documented files with brief descriptions:
o * APDB.h | The Application Descriptor Block (APDB)
o * AuthenticationBlock.h | Authentication Block
o * BLDB.h | Bootloader Descriptor Block (BLDB)
o * Download.hpp | Download Library API
o * FIDB.h | FPGA IP Descriptor Block (FIDB)
\ * ptypes_apdb.h | APDB target abstraction


TTCDownloadLibrary: APDB.h File Reference

  • File List
  • Globals
  • release
  • inc
Data Structures | Macros | Typedefs
APDB.h File Reference

The Application Descriptor Block (APDB) More...

#include "ptypes_apdb.h"
Include dependency graph for APDB.h:
This graph shows which files directly or indirectly include this file:

Data Structures

struct | bl_t_date_
Date structure. More...
struct | bl_t_can_id_
CAN ID structure. More...
struct | bl_apdb_
APDB structure. More...

Macros

#define | APDB_VERSION 0x00000206UL
APDB flags

Defined APDB flags.

#define | APDB_FLAGS_ABRD_ENABLE 0x00000001UL
#define | APDB_FLAGS_CRC64_ENABLE 0x40000000UL
#define | APDB_FLAGS_MULTI_APP 0x80000000UL

Typedefs

typedef struct bl_t_date_ | BL_T_DATE
Date structure. More...
typedef struct bl_t_can_id_ | BL_T_CAN_ID
CAN ID structure.
typedef struct bl_apdb_ | BL_APDB
APDB structure. More...

Variables

Application Descriptor Block (APDB)

The APDB, which is defined by the user.

volatile const BL_APDB Apdb_t

Detailed Description

The Application Descriptor Block (APDB)

Contains the definition for the application descriptor block. This block contains information about a certain application, such as connection settings for CAN and Ethernet, application CRC and the application entry point.

The bootloader needs this information to determine whether or not an application is valid and where the application actually starts. For this reason the field BL_APDB.MainAddress must be provided by the application. Note that some fields are automatically provided by the TTC-Downloader.

APDB Usage:

  • Example for APDB definition

APDB Code Example

Example for using the APDB

Example for APDB definition in an application

volatile const BL_APDB Apdb_t =
{
APDB_VERSION, // APDB version
{0}, // Flash date (provided by the TTC-Downloader)
// Build date
{((((RTS_TTC_FLASH_DATE_YEAR) & 0x0FFF) << 0) |
(((RTS_TTC_FLASH_DATE_MONTH) & 0x0F ) << 12) |
(((RTS_TTC_FLASH_DATE_DAY) & 0x1F ) << 16) |
(((RTS_TTC_FLASH_DATE_HOUR) & 0x1F ) << 21) |
(((RTS_TTC_FLASH_DATE_MINUTE) & 0x3F ) << 26))},
0, // Node type (provided by the TTC-Downloader)
0, // CRC start address (provided by the TTC-Downloader)
0, // Code size (provided by the TTC-Downloader)
0, // Legacy application CRC (provided by the TTC-Downloader)
0, // Application CRC (provided by the TTC-Downloader)
1, // Node number
0, // CRC seed (provided by the TTC-Downloader)
0, // Flags
0, // Hook 1
0, // Hook 2
0, // Hook 3
APPL_START, // Start address, i.e., application entry point
{0, 1}, // CAN download ID (standard format, ID 0x1)
{0, 2}, // CAN upload ID (standard format, ID 0x2)
0, // Legacy header CRC (provided by the TTC-Downloader)
// Application version (major.minor.revision)
((((ubyte4)REVISION_NUMBER) << 0) |
(((ubyte4) MINOR_NUMBER) << 16) |
(((ubyte4) MAJOR_NUMBER) << 24)),
500, // CAN baud rate in kbps
0, // CAN channel
0, // Password (disable password protection)
0, // Magic seed (provided by the TTC-Downloader)
{ 10, 100, 30, 200}, // Target IP address (HY-TTC 500 family only)
{255, 255, 0, 0}, // Subnet mask (HY-TTC 500 family only)
{239, 0, 0, 1}, // Multicast IP address (HY-TTC 500 family only)
0, // Debug key
0, // Automatic baud rate detection timeout in seconds
// (HY-TTC 30X family only)
0x00, // Manufacturer ID (only required for applications that
// are flashed during production of the ECU, provided by
// TTControl GmbH)
0x00, // Application ID (only required for applications that
// are flashed during production of the ECU, provided by
// TTControl GmbH)
{0}, // Reserved, must be set to zero
0 // Header CRC (provided by the TTC-Downloader)
};

Macro Definition Documentation

#define APDB_FLAGS_ABRD_ENABLE 0x00000001UL

Enables automatic baudrate detection at start-up (HY-TTC 30X family only). Access mode: read/write.

#define APDB_FLAGS_CRC64_ENABLE 0x40000000UL

Indicates whether or not CRC-64 is used for application CRC. Access mode: read only.

#define APDB_FLAGS_MULTI_APP 0x80000000UL

Indicates whether or not the app- lication is distributed over multiple (incoherent) application regions. Access mode: read only.

#define APDB_VERSION 0x00000206UL

Current APDB version is version 2.6. This value should be set for field BL_APDB.APDBVersion.

Typedef Documentation

typedef struct bl_apdb_ BL_APDB

APDB structure.

Data structure for accessing the Application Descriptor Block.

typedef struct bl_t_date_ BL_T_DATE

Date structure.

Data structure for saving dates like flash or build date.


TTCDownloadLibrary: AuthenticationBlock.h File Reference

  • File List
  • Globals
  • release
  • inc
Data Structures | Macros | Typedefs
AuthenticationBlock.h File Reference

Authentication Block. More...

#include "APDB.h"
Include dependency graph for AuthenticationBlock.h:
This graph shows which files directly or indirectly include this file:

Data Structures

struct auth_block_t
Authentication block structure. More...

Macros

#define | AUTH_VERSION 0x00000100UL
#define | AUTH_SIZE 40U
Authentication block flags

Defined authentication block flags.

#define | BLDB_FLAG_RESERVED_0 0x00000001UL
#define | BLDB_FLAG_RESERVED_1 0x00000002UL
#define | BLDB_FLAG_RESERVED_2 0x00000004UL
#define | BLDB_FLAG_RESERVED_3 0x00000008UL
#define | BLDB_FLAG_RESERVED_4 0x00000010UL
#define | BLDB_FLAG_RESERVED_5 0x00000020UL
#define | BLDB_FLAG_RESERVED_6 0x00000040UL
#define | BLDB_FLAG_RESERVED_7 0x00000080UL
#define | BLDB_FLAG_RESERVED_8 0x00000100UL
#define | BLDB_FLAG_RESERVED_9 0x00000200UL
#define | BLDB_FLAG_RESERVED_10 0x00000400UL
#define | BLDB_FLAG_RESERVED_11 0x00000800UL
#define | BLDB_FLAG_RESERVED_12 0x00001000UL
#define | BLDB_FLAG_RESERVED_13 0x00002000UL
#define | BLDB_FLAG_RESERVED_14 0x00004000UL
#define | BLDB_FLAG_RESERVED_15 0x00008000UL
#define | BLDB_FLAG_RESERVED_16 0x00010000UL
#define | BLDB_FLAG_RESERVED_17 0x00020000UL
#define | BLDB_FLAG_RESERVED_18 0x00040000UL
#define | BLDB_FLAG_RESERVED_19 0x00080000UL
#define | BLDB_FLAG_RESERVED_20 0x00100000UL
#define | BLDB_FLAG_RESERVED_21 0x00200000UL
#define | BLDB_FLAG_RESERVED_22 0x00400000UL
#define | BLDB_FLAG_RESERVED_23 0x00800000UL
#define | BLDB_FLAG_RESERVED_24 0x01000000UL
#define | BLDB_FLAG_RESERVED_25 0x02000000UL
#define | BLDB_FLAG_RESERVED_26 0x04000000UL
#define | BLDB_FLAG_RESERVED_27 0x08000000UL
#define | BLDB_FLAG_RESERVED_28 0x10000000UL
#define | BLDB_FLAG_RESERVED_29 0x20000000UL
#define | BLDB_FLAG_RESERVED_30 0x40000000UL
#define | BLDB_FLAG_RESERVED_31 0x80000000UL

Typedefs

typedef struct auth_block_t AUTH_BLOCK_T
Authentication block structure. More...

Detailed Description

Authentication Block.

Contains the authentication data for the bootloader and FPGA IP descriptor blocks.

The authentication block contains authentication data for the bootloader and FPGA IP descriptor blocks.

Macro Definition Documentation

#define AUTH_SIZE 40U

The authentication block's size in bytes.

#define AUTH_VERSION 0x00000100UL

Current authentication block version is version 1.0.

#define BLDB_FLAG_RESERVED_0 0x00000001UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_1 0x00000002UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_10 0x00000400UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_11 0x00000800UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_12 0x00001000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_13 0x00002000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_14 0x00004000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_15 0x00008000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_16 0x00010000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_17 0x00020000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_18 0x00040000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_19 0x00080000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_2 0x00000004UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_20 0x00100000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_21 0x00200000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_22 0x00400000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_23 0x00800000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_24 0x01000000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_25 0x02000000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_26 0x04000000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_27 0x08000000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_28 0x10000000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_29 0x20000000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_3 0x00000008UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_30 0x40000000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_31 0x80000000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_4 0x00000010UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_5 0x00000020UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_6 0x00000040UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_7 0x00000080UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_8 0x00000100UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_9 0x00000200UL

Reserved for future use.

Typedef Documentation

typedef struct auth_block_t AUTH_BLOCK_T

Authentication block structure.

Data structure for authenticating bootloader and FPGA IP descriptor blocks.


TTCDownloadLibrary: BLDB.h File Reference

  • File List
  • Globals
  • release
  • inc
Data Structures | Macros | Typedefs
BLDB.h File Reference

Bootloader Descriptor Block (BLDB) More...

#include "APDB.h"
#include "AuthenticationBlock.h"
Include dependency graph for BLDB.h:
This graph shows which files directly or indirectly include this file:

Data Structures

struct bldb_t
BLDB structure. More...

Macros

#define | BLDB_VERSION 0x00000100UL
#define | BLDB_AUTH_OFFSET 88U
BLDB flags

Defined BLDB flags.

#define | BLDB_FLAG_TYPE 0x00000001UL
#define | BLDB_FLAG_RESERVED_1 0x00000002UL
#define | BLDB_FLAG_RESERVED_2 0x00000004UL
#define | BLDB_FLAG_RESERVED_3 0x00000008UL
#define | BLDB_FLAG_RESERVED_4 0x00000010UL
#define | BLDB_FLAG_RESERVED_5 0x00000020UL
#define | BLDB_FLAG_RESERVED_6 0x00000040UL
#define | BLDB_FLAG_RESERVED_7 0x00000080UL
#define | BLDB_FLAG_RESERVED_8 0x00000100UL
#define | BLDB_FLAG_RESERVED_9 0x00000200UL
#define | BLDB_FLAG_RESERVED_10 0x00000400UL
#define | BLDB_FLAG_RESERVED_11 0x00000800UL
#define | BLDB_FLAG_RESERVED_12 0x00001000UL
#define | BLDB_FLAG_RESERVED_13 0x00002000UL
#define | BLDB_FLAG_RESERVED_14 0x00004000UL
#define | BLDB_FLAG_RESERVED_15 0x00008000UL
#define | BLDB_FLAG_RESERVED_16 0x00010000UL
#define | BLDB_FLAG_RESERVED_17 0x00020000UL
#define | BLDB_FLAG_RESERVED_18 0x00040000UL
#define | BLDB_FLAG_RESERVED_19 0x00080000UL
#define | BLDB_FLAG_RESERVED_20 0x00100000UL
#define | BLDB_FLAG_RESERVED_21 0x00200000UL
#define | BLDB_FLAG_RESERVED_22 0x00400000UL
#define | BLDB_FLAG_RESERVED_23 0x00800000UL
#define | BLDB_FLAG_RESERVED_24 0x01000000UL
#define | BLDB_FLAG_RESERVED_25 0x02000000UL
#define | BLDB_FLAG_RESERVED_26 0x04000000UL
#define | BLDB_FLAG_RESERVED_27 0x08000000UL
#define | BLDB_FLAG_RESERVED_28 0x10000000UL
#define | BLDB_FLAG_RESERVED_29 0x20000000UL
#define | BLDB_FLAG_RESERVED_30 0x40000000UL
#define | BLDB_FLAG_RESERVED_31 0x80000000UL

Typedefs

typedef struct bldb_t BLDB_T
BLDB structure. More...

Detailed Description

Bootloader Descriptor Block (BLDB)

Contains the definition for the bootloader descriptor block.

The bootloader descriptor block contains information about the bootloader and the target. Note that the bootloader descriptor block cannot be modified.

Macro Definition Documentation

#define BLDB_AUTH_OFFSET 88U

The authentication block's offset in bytes.

#define BLDB_FLAG_RESERVED_1 0x00000002UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_10 0x00000400UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_11 0x00000800UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_12 0x00001000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_13 0x00002000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_14 0x00004000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_15 0x00008000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_16 0x00010000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_17 0x00020000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_18 0x00040000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_19 0x00080000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_2 0x00000004UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_20 0x00100000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_21 0x00200000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_22 0x00400000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_23 0x00800000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_24 0x01000000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_25 0x02000000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_26 0x04000000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_27 0x08000000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_28 0x10000000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_29 0x20000000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_3 0x00000008UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_30 0x40000000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_31 0x80000000UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_4 0x00000010UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_5 0x00000020UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_6 0x00000040UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_7 0x00000080UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_8 0x00000100UL

Reserved for future use.

#define BLDB_FLAG_RESERVED_9 0x00000200UL

Reserved for future use.

#define BLDB_FLAG_TYPE 0x00000001UL

Indicates the bootloader type:

  • 0 ... first stage bootloader
  • 1 ... second stage bootloader
#define BLDB_VERSION 0x00000100UL

Current BLDB version is version 1.0.

Typedef Documentation

typedef struct bldb_t BLDB_T

BLDB structure.

Data structure for accessing the Bootloader Descriptor Block.


TTCDownloadLibrary: Download.hpp File Reference

  • File List
  • Globals
  • release
  • inc
Data Structures | Macros | Typedefs | Functions
Download.hpp File Reference

Download Library API. More...

#include <cstdint>
#include "APDB.h"
#include "BLDB.h"
#include "FIDB.h"
Include dependency graph for Download.hpp:

Data Structures

struct | DLDCANIdentifier_t
CAN Identifier. More...
struct | DLDIPAddress_t
IP Address. More...
struct | DLDMemoryInfo_t
Memory Information. More...
struct | DLDCPUInfo_t
CPU Information. More...
struct | DLDIconInfo_t
Icon Information. More...
struct | DLDDriverInfo_t
Driver Information. More...
struct | DLDNodeInfo_t
Node Information. More...
struct | DLDTargetInfo_t
Target Information. More...
struct | DLDAPDB_t
APDB. More...
struct | DLDBLDB_t
BLDB. More...
struct | DLDFIDB_t
FIDB. More...

Macros

#define | DLD_MAX_STRING_LENGTH 128U
Result

Return values of the download library functions

#define | DLD_RESULT_OK 0
#define | DLD_RESULT_INVALID_PARAMETER 1
#define | DLD_RESULT_INVALID_SIGNATURE 2
#define | DLD_RESULT_FILE_NOT_FOUND 3
#define | DLD_RESULT_INVALID_FORMAT 4
#define | DLD_RESULT_INVALID_FILE 5
#define | DLD_RESULT_INVALID_HW_ID 6
#define | DLD_RESULT_ACCESS_DENIED 7
#define | DLD_RESULT_INVALID_OPERATION 8
#define | DLD_RESULT_OPERATION_FAILED 9
Log Level

Log levels used for classification/filtering of log messages

#define | DLD_LOG_LEVEL_DEBUG 0U
#define | DLD_LOG_LEVEL_INFO 1U
#define | DLD_LOG_LEVEL_WARNING 2U
#define | DLD_LOG_LEVEL_ERROR 3U
Driver Type

Supported driver types

#define | DLD_DRIVER_TYPE_CAN 0U
#define | DLD_DRIVER_TYPE_UDP 1U
CAN Driver

Selects the CAN driver to be used

#define | DLD_CAN_DRIVER_PCAN_USB 0U
#define | DLD_CAN_DRIVER_PCAN_PCI 1U
#define | DLD_CAN_DRIVER_CANPRO_USB 2U
CAN Channel

Selects the CAN channel to be used

#define | DLD_CAN_CHANNEL_0 0U
#define | DLD_CAN_CHANNEL_1 1U
#define | DLD_CAN_CHANNEL_2 2U
#define | DLD_CAN_CHANNEL_3 3U
#define | DLD_CAN_CHANNEL_4 4U
#define | DLD_CAN_CHANNEL_5 5U
#define | DLD_CAN_CHANNEL_6 6U
#define | DLD_CAN_CHANNEL_7 7U
CAN Baudrate

Selects the CAN baudrate to be used

#define | DLD_CAN_BAUD_RATE_5K 5U
#define | DLD_CAN_BAUD_RATE_10K 10U
#define | DLD_CAN_BAUD_RATE_20K 20U
#define | DLD_CAN_BAUD_RATE_33K 33U
#define | DLD_CAN_BAUD_RATE_47K 47U
#define | DLD_CAN_BAUD_RATE_50K 50U
#define | DLD_CAN_BAUD_RATE_83K 83U
#define | DLD_CAN_BAUD_RATE_95K 95U
#define | DLD_CAN_BAUD_RATE_100K 100U
#define | DLD_CAN_BAUD_RATE_125K 125U
#define | DLD_CAN_BAUD_RATE_250K 250U
#define | DLD_CAN_BAUD_RATE_500K 500U
#define | DLD_CAN_BAUD_RATE_800K 800U
#define | DLD_CAN_BAUD_RATE_1M 1000U
CAN Identifier Format

Selects the CAN identifier format to be used

#define | DLD_CAN_ID_STANDARD 0U
#define | DLD_CAN_ID_EXTENDED 1U
Endian

Provides information about the endian of a target CPU

#define | DLD_BIG_ENDIAN 0U
#define | DLD_LITTLE_ENDIAN 1U
Action

Specifies the currently ongoing action

#define | DLD_ACTION_NONE 0U
#define | DLD_ACTION_CONNECTING 1U
#define | DLD_ACTION_IDENTIFYING 2U
#define | DLD_ACTION_AUTHENTICATING 3U
#define | DLD_ACTION_DOWNLOADING_2ND 4U
#define | DLD_ACTION_RETRIEVING_NODE_INFO 5U
#define | DLD_ACTION_ERASING 6U
#define | DLD_ACTION_READING 7U
#define | DLD_ACTION_WRITING 8U
#define | DLD_ACTION_FINALIZING_SECTORS 9U
Item

Specifies a certain item for which memory information can be retrieved

#define | DLD_ITEM_PDB 0U
#define | DLD_ITEM_BOOTLOADER 1U
#define | DLD_ITEM_BLDB 2U
#define | DLD_ITEM_SECOND_STAGE 3U
#define | DLD_ITEM_SECOND_STAGE_BLDB 4U
#define | DLD_ITEM_SECOND_STAGE_BUFFER 5U
#define | DLD_ITEM_FPGA_IP_CORE 6U
#define | DLD_ITEM_FIDB 7U
#define | DLD_ITEM_CODESYS 8U
#define | DLD_ITEM_APPLICATION 9U
#define | DLD_ITEM_APDB 10U
#define | DLD_ITEM_CRC_TABLE 11U
#define | DLD_ITEM_CONFIGURATION_DATA 12U
#define | DLD_ITEM_INTERNAL_FLASH 13U
#define | DLD_ITEM_EXTERNAL_FLASH 14U
#define | DLD_ITEM_INTERNAL_EEPROM 15U
#define | DLD_ITEM_EXTERNAL_EEPROM 16U

Typedefs

typedef void * | DLDCustomData_t
Custom Data Pointer Type. More...
typedef int32_t | DLDResult_t
Result Type. More...
typedef void(* | DLDLogCB_t )(uint32_t severity, const char *const message)
Log Callback Type. More...
typedef int32_t(* | DLDDriverInitCB_t )(void *custom_data)
Driver Initialization Callback Type. More...
typedef int32_t(* | DLDDriverDeinitCB_t )(void *custom_data)
Driver Deinitialization Callback Type. More...
typedef int32_t(* | DLDDriverUDPReadCB_t )(uint8_t *const data, uint32_t length, uint32_t *const bytes_read, void *custom_data)
Driver UDP Read Callback Type. More...
typedef int32_t(* | DLDDriverUDPWriteCB_t )(const uint8_t *const data, uint32_t length, void *custom_data)
Driver UDP Write Callback Type. More...
typedef int32_t(* | DLDDriverCANReadCB_t )(DLDCANIdentifier_t can_id, uint8_t *const data, uint32_t length, uint32_t *const bytes_read, void *custom_data)
Driver CAN Read Callback Type. More...
typedef int32_t(* | DLDDriverCANWriteCB_t )(DLDCANIdentifier_t can_id, const uint8_t *const data, uint32_t length, void *custom_data)
Driver CAN Write Callback Type. More...
typedef int32_t(* | DLDPowerCycleCB_t )(void)
Power Cycle Callback Type. More...
typedef int32_t(* | DLDProgressCB_t )(uint8_t current_action, uint8_t current_progress)
Progress Callback Type. More...

Functions

DLDResult_t DOWNLOAD_API | DLD_Get_Version (uint8_t *const major, uint8_t *const minor, uint16_t *const patch_level)
Returns the version of the DLD Download Library. More...
DLDResult_t DOWNLOAD_API | DLD_Init (const char *const target_directory, uint32_t log_level, const char *const log_file, DLDProgressCB_t progress_callback, DLDPowerCycleCB_t power_cycle_callback)
Initializes the DLD Download Library. More...
DLDResult_t DOWNLOAD_API | DLD_Init_Custom (const char *const target_directory, uint32_t log_level, DLDLogCB_t log_callback, DLDProgressCB_t progress_callback, DLDPowerCycleCB_t power_cycle_callback)
Initializes the DLD Download Library. More...
DLDResult_t DOWNLOAD_API | DLD_Deinit (void)
Deinitializes the DLD Download Library. More...
DLDResult_t DOWNLOAD_API | DLD_Set_Log_Level (uint32_t log_level)
Sets the log level of the active log channel. More...
DLDResult_t DOWNLOAD_API | DLD_Write_Log (uint32_t log_level, const char *const message)
Writes a log message to the active log channel. More...
DLDResult_t DOWNLOAD_API | DLD_Driver_Register_CAN (uint32_t driver, uint8_t channel, uint16_t baudrate, DLDCANIdentifier_t download_id, DLDCANIdentifier_t upload_id)
Registers a CAN driver for communication. More...
DLDResult_t DOWNLOAD_API | DLD_Driver_Register_Custom_CAN (DLDCANIdentifier_t download_id, DLDCANIdentifier_t upload_id, DLDDriverInitCB_t init_callback, DLDDriverDeinitCB_t deinit_callback, DLDDriverCANReadCB_t read_callback, DLDDriverCANWriteCB_t write_callback, DLDCustomData_t custom_data)
Registers a custom CAN driver for communication. More...
DLDResult_t DOWNLOAD_API | DLD_Driver_Register_UDP (DLDIPAddress_t local_address, DLDIPAddress_t multicast_address, uint16_t port_number)
Registers an UDP driver for communication. More...
DLDResult_t DOWNLOAD_API | DLD_Driver_Register_Custom_UDP (DLDDriverInitCB_t init_callback, DLDDriverDeinitCB_t deinit_callback, DLDDriverUDPReadCB_t read_callback, DLDDriverUDPWriteCB_t write_callback, DLDCustomData_t custom_data)
Registers a custom UDP driver for communication. More...
DLDResult_t DOWNLOAD_API | DLD_Driver_Deregister_All (void)
Deregisters all registered drivers. More...
DLDResult_t DOWNLOAD_API | DLD_Driver_Init (void)
Initializes all registered drivers. More...
DLDResult_t DOWNLOAD_API | DLD_Driver_Deinit (void)
Deinitializes all registered drivers. More...
DLDResult_t DOWNLOAD_API | DLD_Connect (const uint8_t *const node_ids, uint8_t size, uint32_t duration, bool automatic_reset, bool compatibility_check, uint16_t *const nodes_found)
Connects to nodes via all registered drivers. More...
DLDResult_t DOWNLOAD_API | DLD_Disconnect (void)
Disconnects from all connected nodes. More...
DLDResult_t DOWNLOAD_API | DLD_Set_Node_Password (uint16_t node, const char *const password)
Sets the password of a connected node. More...
DLDResult_t DOWNLOAD_API | DLD_Get_Node_Info (uint16_t node, DLDNodeInfo_t *const node_info)
Retrieves node information of a connected node. More...
DLDResult_t DOWNLOAD_API | DLD_Get_Target_Info (uint16_t node, DLDTargetInfo_t *const target_info)
Retrieves target information of a connected node. More...
DLDResult_t DOWNLOAD_API | DLD_Get_Memory_Info (uint16_t node, uint8_t item, uint8_t index, DLDMemoryInfo_t *const memory_info, char *const name)
Retrieves memory information of a connected node. More...
DLDResult_t DOWNLOAD_API | DLD_Get_APDB (uint16_t node, const char *const application, DLDAPDB_t *const apdb)
Retrieves an APDB of a connected node. More...
DLDResult_t DOWNLOAD_API | DLD_Set_APDB (uint16_t node, const char *const application, const DLDAPDB_t *const apdb)
Sets an APDB of a connected node. More...
DLDResult_t DOWNLOAD_API | DLD_Get_BLDB (uint16_t node, DLDBLDB_t *const bldb)
Retrieves the BLDB of a connected node. More...
DLDResult_t DOWNLOAD_API | DLD_Get_FIDB (uint16_t node, DLDFIDB_t *const fidb)
Retrieves the FIDB of a connected node. More...
DLDResult_t DOWNLOAD_API | DLD_Read_Flash (uint16_t node, uint32_t flash_address, uint32_t length, uint8_t *const data)
Reads data from flash memory of a connected node. More...
DLDResult_t DOWNLOAD_API | DLD_Write_Flash (uint16_t node, uint32_t flash_address, uint32_t length, const uint8_t *const data)
Writes data to the flash memory of a connected node. More...
DLDResult_t DOWNLOAD_API | DLD_Erase_Flash (uint16_t node, uint32_t flash_address, uint32_t length)
Erases the given range in flash memory of a connected node. More...
DLDResult_t DOWNLOAD_API | DLD_Read_EEPROM (uint16_t node, uint32_t eeprom_address, uint32_t length, uint8_t *const data)
Reads data from EEPROM of a connected node. More...
DLDResult_t DOWNLOAD_API | DLD_Write_EEPROM (uint16_t node, uint32_t eeprom_address, uint32_t length, const uint8_t *const data)
Writes data to the EEPROM of a connected node. More...
DLDResult_t DOWNLOAD_API | DLD_Erase_EEPROM (uint16_t node, uint32_t eeprom_address, uint32_t length)
Erases the given range in EEPROM of a connected node. More...
DLDResult_t DOWNLOAD_API | DLD_Download_Flash_File (uint16_t node, const char *const file_name)
Downloads a file to the flash memory of a connected node. More...
DLDResult_t DOWNLOAD_API | DLD_Download_EEPROM_File (uint16_t node, const char *const file_name)
Downloads a file to EEPROM of a connected node. More...
DLDResult_t DOWNLOAD_API | DLD_Parse_Arguments (const char **const arguments, uint32_t size)
Parses an array of arguments. More...

Detailed Description

Download Library API.

The download library API provides functions to read and modify the memory of the complete range of ECUs and I/O modules produced by TTControl GmbH.

Basic usage of the download library

The basic usage of the download library is as follows:

  • initialize the library
  • register driver(s) used for communication
  • initialize driver(s)
  • connect to node(s)
  • perform one or more of the following tasks:
    • read/write/erase memory
    • download hex file
  • disconnect from node(s)
  • deinitialize driver(s)
  • deregister driver(s)
  • deinitialize the library

Example:

int main(int argc, char *argv[])
{
DLDResut_t result;
unsigned short nodes_found = 0U;
DLDIPAddress_t local_address = { {10, 0, 0, 1}, DLD_BIG_ENDIAN };
DLDIPAddress_t multicast_address = { {239, 0, 0, 1}, DLD_BIG_ENDIAN };
// initialize the library
result = DLD_Init( "./targets" // directory containing the target configuration files
, DLD_LOG_LEVEL_INFO // log only messages with severity above or equal to this log level
, "output.log" // the log file
, NULL // do not use progress callback
, NULL // do not use power cycle callback
);
if ( result != DLD_RESULT_OK )
{
// an error occurred
return result;
}
// register UDP driver
result = DLD_Driver_Register_UDP( local_address // local IPv4 address (used to specifies the network interface card)
, multicast_address // multicast IPv4 address (must match the configuration of the node)
, 8500 // port number
);
if ( result != DLD_RESULT_OK )
{
// an error occurred
return result;
}
// initialize UDP driver
result = DLD_Driver_Init();
if ( result != DLD_RESULT_OK )
{
// an error occurred
return result;
}
// connect to nodes
result = DLD_Connect( NULL // scan all node numbers
, 0UL // see line above
, 7UL // send connect messages for 7 seconds
, true // perform automatic reset
, true // perform compatibility check
, &nodes_found // after the function returns, this variable holds the number of connected nodes
);
if ( result != DLD_RESULT_OK )
{
// an error occurred
return result;
}
// download application to first node
if ( nodes_found > 0U )
{
result = DLD_Download_Flash_File( 0U // download application to first node
, "application.hex" // the application file
);
if ( result != DLD_RESULT_OK )
{
// an error occurred
return result;
}
}
// disconnect from nodes
result = DLD_Disconnect();
if ( result != DLD_RESULT_OK )
{
// an error occurred
return result;
}
// deinitialize UDP driver
result = DLD_Driver_Deinit();
if ( result != DLD_RESULT_OK )
{
// an error occurred
return result;
}
// deregister UDP driver
result = DLD_Driver_Deregister_All();
if ( result != DLD_RESULT_OK )
{
// an error occurred
return result;
}
// deinitialize the library
result = DLD_Deinit();
// now we are done
return result;
}

Macro Definition Documentation

#define DLD_ACTION_AUTHENTICATING 3U

Signals that identified nodes are authenticated right away.

#define DLD_ACTION_CONNECTING 1U

Signals that the connection to the node's first stage bootloader is going to be established.

#define DLD_ACTION_DOWNLOADING_2ND 4U

Signals that the second stage bootloader gets downloaded to an authenticated node.

#define DLD_ACTION_ERASING 6U

Signals that a node's memory gets erased.

#define DLD_ACTION_FINALIZING_SECTORS 9U

Signals that a node's flash sectors get post processed after they have been modified.

#define DLD_ACTION_IDENTIFYING 2U

Signals that connected nodes are identified right away.

#define DLD_ACTION_NONE 0U

No action is ongoing.

#define DLD_ACTION_READING 7U

Signals that data gets read from a node's memory.

#define DLD_ACTION_RETRIEVING_NODE_INFO 5U

Signals that various information is going to be retrieved from an authenticated node.

#define DLD_ACTION_WRITING 8U

Signals that data gets written to a node's memory.

#define DLD_BIG_ENDIAN 0U

Big endian (most significant byte at lowest address).

#define DLD_CAN_BAUD_RATE_100K 100U

CAN baudrate 100kbps.

#define DLD_CAN_BAUD_RATE_10K 10U

CAN baudrate 10kbps.

#define DLD_CAN_BAUD_RATE_125K 125U

CAN baudrate 125kbps.

#define DLD_CAN_BAUD_RATE_1M 1000U

CAN baudrate 1000kbps.

#define DLD_CAN_BAUD_RATE_20K 20U

CAN baudrate 20kbps.

#define DLD_CAN_BAUD_RATE_250K 250U

CAN baudrate 250kbps.

#define DLD_CAN_BAUD_RATE_33K 33U

CAN baudrate 33kbps.

#define DLD_CAN_BAUD_RATE_47K 47U

CAN baudrate 47kbps.

#define DLD_CAN_BAUD_RATE_500K 500U

CAN baudrate 500kbps.

#define DLD_CAN_BAUD_RATE_50K 50U

CAN baudrate 50kbps.

#define DLD_CAN_BAUD_RATE_5K 5U

CAN baudrate 5kbps.

#define DLD_CAN_BAUD_RATE_800K 800U

CAN baudrate 800kbps.

#define DLD_CAN_BAUD_RATE_83K 83U

CAN baudrate 83kbps.

#define DLD_CAN_BAUD_RATE_95K 95U

CAN baudrate 95kbps.

#define DLD_CAN_CHANNEL_0 0U

CAN channel 0.

#define DLD_CAN_CHANNEL_1 1U

CAN channel 1.

#define DLD_CAN_CHANNEL_2 2U

CAN channel 2.

#define DLD_CAN_CHANNEL_3 3U

CAN channel 3.

#define DLD_CAN_CHANNEL_4 4U

CAN channel 4.

#define DLD_CAN_CHANNEL_5 5U

CAN channel 5.

#define DLD_CAN_CHANNEL_6 6U

CAN channel 6.

#define DLD_CAN_CHANNEL_7 7U

CAN channel 7.

#define DLD_CAN_DRIVER_CANPRO_USB 2U

Driver for Softing CANpro USB adapters.

#define DLD_CAN_DRIVER_PCAN_PCI 1U

Driver for PCAN-PCI and PCAN-PCI Express adapters.

#define DLD_CAN_DRIVER_PCAN_USB 0U

Driver for PCAN-USB adapters.

#define DLD_CAN_ID_EXTENDED 1U

CAN extended identifier (29-bit).

#define DLD_CAN_ID_STANDARD 0U

CAN standard identifier (11-bit).

#define DLD_DRIVER_TYPE_CAN 0U

CAN driver.

#define DLD_DRIVER_TYPE_UDP 1U

UDP driver.

#define DLD_ITEM_APDB 10U

A certain application's descriptor block.

#define DLD_ITEM_APPLICATION 9U

A C application.

#define DLD_ITEM_BLDB 2U

The first stage bootloader's descriptor block.

#define DLD_ITEM_BOOTLOADER 1U

The first stage bootloader.

#define DLD_ITEM_CODESYS 8U

The CODESYS application.

#define DLD_ITEM_CONFIGURATION_DATA 12U

A configuration data region.

#define DLD_ITEM_CRC_TABLE 11U

The CRC table.

#define DLD_ITEM_EXTERNAL_EEPROM 16U

The external EEPROM.

#define DLD_ITEM_EXTERNAL_FLASH 14U

The external flash memory.

#define DLD_ITEM_FIDB 7U

The FPGA IP core's descriptor block.

#define DLD_ITEM_FPGA_IP_CORE 6U

The FPGA IP core.

#define DLD_ITEM_INTERNAL_EEPROM 15U

The internal EEPROM.

#define DLD_ITEM_INTERNAL_FLASH 13U

The internal flash memory.

#define DLD_ITEM_PDB 0U

The product descriptor block.

#define DLD_ITEM_SECOND_STAGE 3U

The second stage bootloader.

#define DLD_ITEM_SECOND_STAGE_BLDB 4U

The second stage bootloader's descriptor block.

#define DLD_ITEM_SECOND_STAGE_BUFFER 5U

The second stage bootloader's RAM buffer.

#define DLD_LITTLE_ENDIAN 1U

Little endian (least significant byte at lowest address).

#define DLD_LOG_LEVEL_DEBUG 0U

Log level for debug messages.

#define DLD_LOG_LEVEL_ERROR 3U

Log level for errors.

#define DLD_LOG_LEVEL_INFO 1U

Log level for notifications.

#define DLD_LOG_LEVEL_WARNING 2U

Log level for warnings.

#define DLD_MAX_STRING_LENGTH 128U

The maximum string length (make sure to provide buffers of at least this size for all output parameters of type char *).

#define DLD_RESULT_ACCESS_DENIED 7

Access to a certain node or memory range has been denied.

#define DLD_RESULT_FILE_NOT_FOUND 3

A file could not be found.

#define DLD_RESULT_INVALID_FILE 5

An invalid file has been provided, i.e., the file's type could not be detected.

#define DLD_RESULT_INVALID_FORMAT 4

The provided file's format is invalid.

#define DLD_RESULT_INVALID_HW_ID 6

The provided file does not match the node's hardware identifier.

#define DLD_RESULT_INVALID_OPERATION 8

The requested operation cannot be performed as at least one prerequisite is not satisfied.

#define DLD_RESULT_INVALID_PARAMETER 1

An invalid parameter has been provided.

#define DLD_RESULT_INVALID_SIGNATURE 2

A configuration file's signature is invalid.

#define DLD_RESULT_OK 0

Everything went fine.

#define DLD_RESULT_OPERATION_FAILED 9

The requested operation failed.

Typedef Documentation

typedef void* DLDCustomData_t

Custom Data Pointer Type.

Pointer to custom data that can be used during registration of callback drivers.

typedef int32_t(* DLDDriverCANReadCB_t)(DLDCANIdentifier_t can_id, uint8_t *const data, uint32_t length, uint32_t *const bytes_read, void *custom_data)

Driver CAN Read Callback Type.

The driver CAN read callback function is called from the DLD Download Library whenever data shall be read from a (registered) custom CAN driver.

Parameters
[in] | can_id | CAN identifier to read data from
[out] | data | Data buffer that shall receive the read bytes
[in] | length | Maximum number of bytes to be read
[out] | bytes_read | Actual number of bytes read
[in] | custom_data | Pointer to the driver's custom data
Returns
int
Return values
0 everything fine
!= 0 failed with device specific error code
Remarks
  • This function must be non-blocking in order to guarantee correct functionality of the DLD Download Library functions.
typedef int32_t(* DLDDriverCANWriteCB_t)(DLDCANIdentifier_t can_id, const uint8_t *const data, uint32_t length, void *custom_data)

Driver CAN Write Callback Type.

The driver CAN write callback function is called from the DLD Download Library whenever data shall be written via a (registered) custom CAN driver.

Parameters
[in] | can_id | CAN identifier to write data to
[in] | data | Buffer containing the data
[in] | length | Number of bytes to be written
[in] | custom_data | Pointer to the driver's custom data
Returns
int
Return values
0 everything fine
!= 0 failed with device specific error code
Remarks
  • This function must be non-blocking in order to guarantee correct functionality of the DLD Download Library functions.
typedef int32_t(* DLDDriverDeinitCB_t)(void *custom_data)

Driver Deinitialization Callback Type.

The driver deinitialization callback function is called from the DLD Download Library whenever a (registered) custom driver needs to be deinitialized.

Parameters
[in] custom_data Pointer to the driver's custom data
Returns
int
Return values
0 everything fine
!= 0 failed with device specific error code
Remarks
  • This function must be non-blocking in order to guarantee correct functionality of the DLD Download Library functions.
typedef int32_t(* DLDDriverInitCB_t)(void *custom_data)

Driver Initialization Callback Type.

The driver initialization callback function is called from the DLD Download Library whenever a (registered) custom driver needs to be initialized.

Parameters
[in] custom_data Pointer to the driver's custom data
Returns
int
Return values
0 everything fine
!= 0 failed with device specific error code
Remarks
  • This function must be non-blocking in order to guarantee correct functionality of the DLD Download Library functions.
typedef int32_t(* DLDDriverUDPReadCB_t)(uint8_t *const data, uint32_t length, uint32_t *const bytes_read, void *custom_data)

Driver UDP Read Callback Type.

The driver UDP read callback function is called from the DLD Download Library whenever data shall be read from a (registered) custom UDP driver.

Parameters
[out] | data | Data buffer that shall receive the read bytes
[in] | length | Maximum number of bytes to be read
[out] | bytes_read | Actual number of bytes read
[in] | custom_data | Pointer to the driver's custom data
Returns
int
Return values
0 everything fine
!= 0 failed with device specific error code
Remarks
  • This function must be non-blocking in order to guarantee correct functionality of the DLD Download Library functions.
typedef int32_t(* DLDDriverUDPWriteCB_t)(const uint8_t *const data, uint32_t length, void *custom_data)

Driver UDP Write Callback Type.

The driver UDP write callback function is called from the DLD Download Library whenever data shall be written via a (registered) custom UDP driver.

Parameters
[in] | data | Buffer containing the data
[in] | length | Number of bytes to be written
[in] | custom_data | Pointer to the driver's custom data
Returns
int
Return values
0 everything fine
!= 0 failed with device specific error code
Remarks
  • This function must be non-blocking in order to guarantee correct functionality of the DLD Download Library functions.
typedef void(* DLDLogCB_t)(uint32_t severity, const char *const message)

Log Callback Type.

Log callback functions can be registered at library initialization in order to allow custom log channels.

Parameters
[in] | severity | The log message's severity
[in] | message | The log message
Returns
void
Remarks
  • This function must be non-blocking in order to guarantee correct functionality of the DLD Download Library functions.
typedef int32_t(* DLDPowerCycleCB_t)(void)

Power Cycle Callback Type.

The power cycle callback function is called from the DLD Download Library whenever a power cycle of connected nodes shall be performed.

Returns
int
Return values
0 everything fine
!= 0 failed to initiate power cycle
Remarks
  • This function must be non-blocking in order to guarantee correct functionality of the DLD Download Library functions.
typedef int32_t(* DLDProgressCB_t)(uint8_t current_action, uint8_t current_progress)

Progress Callback Type.

The progress callback function is called from the DLD Download Library to report the progress of the current action. It can be used by the application to abort an ongoing action.

Parameters
[in] | current_action | The current active action
[in] | current_progress | The current action's progress (in percent)
Returns
int
Return values
0 everything fine
!= 0 application requests abort of the current action
Remarks
  • This function must be non-blocking in order to guarantee correct functionality of the DLD Download Library functions.
typedef int32_t DLDResult_t

Result Type.

Return type of all DLD download library functions.

Function Documentation

DLDResult_t DOWNLOAD_API DLD_Connect | ( | const uint8_t *const | node_ids,
 |  | uint8_t | size,
 |  | uint32_t | duration,
 |  | bool | automatic_reset,
 |  | bool | compatibility_check,
 |  | uint16_t *const | nodes_found
 | ) |  |

Connects to nodes via all registered drivers.

This function connects to nodes via all registered drivers.

Parameters
[in] | node_ids | Array of node IDs (i.e., node numbers) to scan for
[in] | size | Size of the node ID array
[in] | duration | Specifies for how many seconds connect messages shall be sent during the connection procedure
[in] | automatic_reset | Indicates whether or not a soft reset shall be performed during the connection procedure
[in] | compatibility_check | Indicates whether or not the compatibility check shall be performed for found nodes
[out] | nodes_found | Returns the number of nodes found
Returns
DLDResult_t
Remarks
  • If the automatic reset flag is set, no power cycle is necessary to connect with nodes executing the CODESYS RTS.
  • Before calling this function, all registered drivers must explicitly be initialized by calling DLD_Driver_Init.
DLDResult_t DOWNLOAD_API DLD_Deinit ( void )

Deinitializes the DLD Download Library.

This function deinitializes the DLD Download Library.

Returns
DLDResult_t
Remarks
  • This function does not disconnect from nodes before deinitializing the library. If the connected nodes shall be reset, the disconnect function must explicitly be called by the application. Otherwise the connected nodes remain in the second stage bootloader until a power cycle is performed.
DLDResult_t DOWNLOAD_API DLD_Disconnect ( void )

Disconnects from all connected nodes.

This function disconnects from all connected nodes, i.e., it performs a soft reset of all connected the nodes.

Returns
DLDResult_t
Remarks
  • After calling this function, all nodes start execution of their respective applications (if present).
DLDResult_t DOWNLOAD_API DLD_Download_EEPROM_File | ( | uint16_t | node,
 |  | const char *const | file_name
 | ) |  |

Downloads a file to EEPROM of a connected node.

This function downloads the given file to the EEPROM of a connected node.

Parameters
[in] | node | Index of the node
[in] | file_name | The file name
Returns
DLDResult_t
Remarks
  • Following input formats are supported: + Intel HEX + Motorola S-Record + CODESYS binary files (*.bin, *.app)
DLDResult_t DOWNLOAD_API DLD_Download_Flash_File | ( | uint16_t | node,
 |  | const char *const | file_name
 | ) |  |

Downloads a file to the flash memory of a connected node.

This function downloads the given file to the flash memory of a connected node.

Parameters
[in] | node | Index of the node
[in] | file_name | The file name
Returns
DLDResult_t
Remarks
  • Following input formats are supported: + Intel HEX + Motorola S-Record + CODESYS binary files (*.bin, *.app)
DLDResult_t DOWNLOAD_API DLD_Driver_Deinit ( void )

Deinitializes all registered drivers.

This function deinitializes all registered drivers.

Returns
DLDResult_t
DLDResult_t DOWNLOAD_API DLD_Driver_Deregister_All ( void )

Deregisters all registered drivers.

This function deregisters all registered drivers.

Returns
DLDResult_t
DLDResult_t DOWNLOAD_API DLD_Driver_Init ( void )

Initializes all registered drivers.

This function initializes all registered drivers.

Returns
DLDResult_t
DLDResult_t DOWNLOAD_API DLD_Driver_Register_CAN | ( | uint32_t | driver,
 |  | uint8_t | channel,
 |  | uint16_t | baudrate,
 |  | DLDCANIdentifier_t | download_id,
 |  | DLDCANIdentifier_t | upload_id
 | ) |  |

Registers a CAN driver for communication.

This function registers a built-in CAN driver for communication.

Parameters
[in] | driver | The CAN driver to be used
[in] | channel | The CAN driver's channel to be used
[in] | baudrate | The CAN baudrate used for communication
[in] | download_id | The CAN identifier used for download direction (host -> target)
[in] | upload_id | The CAN identifier used for upload direction (target -> host)
Returns
DLDResult_t
DLDResult_t DOWNLOAD_API DLD_Driver_Register_Custom_CAN | ( | DLDCANIdentifier_t | download_id,
 |  | DLDCANIdentifier_t | upload_id,
 |  | DLDDriverInitCB_t | init_callback,
 |  | DLDDriverDeinitCB_t | deinit_callback,
 |  | DLDDriverCANReadCB_t | read_callback,
 |  | DLDDriverCANWriteCB_t | write_callback,
 |  | DLDCustomData_t | custom_data
 | ) |  |

Registers a custom CAN driver for communication.

This function registers a custom CAN driver for communication.

Parameters
[in] | download_id | The CAN identifier used for download direction (host -> target)
[in] | upload_id | The CAN identifier used for upload direction (target -> host)
[in] | init_callback | Pointer to the driver initialization callback function
[in] | deinit_callback | Pointer to the driver deinitialization callback function
[in] | read_callback | Pointer to the driver CAN read callback function
[in] | write_callback | Pointer to the driver CAN write callback function
[in] | custom_data | Pointer to the driver's custom data
Returns
DLDResult_t
DLDResult_t DOWNLOAD_API DLD_Driver_Register_Custom_UDP | ( | DLDDriverInitCB_t | init_callback,
 |  | DLDDriverDeinitCB_t | deinit_callback,
 |  | DLDDriverUDPReadCB_t | read_callback,
 |  | DLDDriverUDPWriteCB_t | write_callback,
 |  | DLDCustomData_t | custom_data
 | ) |  |

Registers a custom UDP driver for communication.

This function registers a custom UDP driver for communication.

Parameters
[in] | init_callback | Pointer to the driver initialization callback function
[in] | deinit_callback | Pointer to the driver deinitialization callback function
[in] | read_callback | Pointer to the driver UDP read callback function
[in] | write_callback | Pointer to the driver UDP write callback function
[in] | custom_data | Pointer to the driver's custom data
Returns
DLDResult_t
DLDResult_t DOWNLOAD_API DLD_Driver_Register_UDP | ( | DLDIPAddress_t | local_address,
 |  | DLDIPAddress_t | multicast_address,
 |  | uint16_t | port_number
 | ) |  |

Registers an UDP driver for communication.

This function registers a built-in UDP driver for communication.

Parameters
[in] | local_address | The host's local IPv4 address
[in] | multicast_address | The multicast IPv4 address used for communication
[in] | port_number | The port number used for communication
Returns
DLDResult_t
DLDResult_t DOWNLOAD_API DLD_Erase_EEPROM | ( | uint16_t | node,
 |  | uint32_t | eeprom_address,
 |  | uint32_t | length
 | ) |  |

Erases the given range in EEPROM of a connected node.

This function erases the given range in EEPROM of a connected node.

Parameters
[in] | node | Index of the node
[in] | eeprom_address | Start address
[in] | length | Number of bytes to be erased
Returns
DLDResult_t
DLDResult_t DOWNLOAD_API DLD_Erase_Flash | ( | uint16_t | node,
 |  | uint32_t | flash_address,
 |  | uint32_t | length
 | ) |  |

Erases the given range in flash memory of a connected node.

This function erases the given range in flash memory of a connected node.

Parameters
[in] | node | Index of the node
[in] | flash_address | Start address
[in] | length | Number of bytes to be erased
Returns
DLDResult_t
DLDResult_t DOWNLOAD_API DLD_Get_APDB | ( | uint16_t | node,
 |  | const char *const | application,
 |  | DLDAPDB_t *const | apdb
 | ) |  |

Retrieves an APDB of a connected node.

This function retrieves an APDB of a connected node.

Parameters
[in] | node | Index of the node
[in] | application | Name of the application
[out] | apdb | Pointer to the APDB structure receiving the data
Returns
DLDResult_t
DLDResult_t DOWNLOAD_API DLD_Get_BLDB | ( | uint16_t | node,
 |  | DLDBLDB_t *const | bldb
 | ) |  |

Retrieves the BLDB of a connected node.

This function retrieves the BLDB of a connected node.

Parameters
[in] | node | Index of the node
[out] | bldb | Pointer to the BLDB structure receiving the data
Returns
DLDResult_t
DLDResult_t DOWNLOAD_API DLD_Get_FIDB | ( | uint16_t | node,
 |  | DLDFIDB_t *const | fidb
 | ) |  |

Retrieves the FIDB of a connected node.

This function retrieves the FIDB of a connected node.

Parameters
[in] | node | Index of the node
[out] | fidb | Pointer to the FIDB structure receiving the data
Returns
DLDResult_t
DLDResult_t DOWNLOAD_API DLD_Get_Memory_Info | ( | uint16_t | node,
 |  | uint8_t | item,
 |  | uint8_t | index,
 |  | DLDMemoryInfo_t *const | memory_info,
 |  | char *const | name
 | ) |  |

Retrieves memory information of a connected node.

This function retrieves the memory information of a certain item of a connected node.

Parameters
[in] | node | Index of the node
[in] | item | The item (see enum_item)
[in] | index | The item's index (only required for items with multiple entries)
[out] | memory_info | Pointer to the memory information structure receiving the data
[out] | name | Pointer to the character array receiving the item's name
Returns
DLDResult_t
DLDResult_t DOWNLOAD_API DLD_Get_Node_Info | ( | uint16_t | node,
 |  | DLDNodeInfo_t *const | node_info
 | ) |  |

Retrieves node information of a connected node.

This function retrieves the node information of a connected node.

Parameters
[in] | node | Index of the node
[out] | node_info | Pointer to the node information structure receiving the data
Returns
DLDResult_t
DLDResult_t DOWNLOAD_API DLD_Get_Target_Info | ( | uint16_t | node,
 |  | DLDTargetInfo_t *const | target_info
 | ) |  |

Retrieves target information of a connected node.

This function retrieves the target information of a connected node.

Parameters
[in] | node | Index of the node
[out] | target_info | Pointer to the target information structure receiving the data
Returns
DLDResult_t
DLDResult_t DOWNLOAD_API DLD_Get_Version | ( | uint8_t *const | major,
 |  | uint8_t *const | minor,
 |  | uint16_t *const | patch_level
 | ) |  |

Returns the version of the DLD Download Library.

This function can be used to retrieve the version of the DLD Download Library.

Parameters
[out] | major | Major number of the DLD Download Library version
[out] | minor | Minor number of the DLD Download Library version
[out] | patch_level | Patch level of the DLD Download Library version
Returns
DLDResult_t
Remarks
  • This function can be called before initializing the DLD Download Library.
DLDResult_t DOWNLOAD_API DLD_Init | ( | const char *const | target_directory,
 |  | uint32_t | log_level,
 |  | const char *const | log_file,
 |  | DLDProgressCB_t | progress_callback,
 |  | DLDPowerCycleCB_t | power_cycle_callback
 | ) |  |

Initializes the DLD Download Library.

This function initializes the DLD Download Library. All log messages are written to the specified log file. By passing a valid pointer to a progress callback function, progress reporting can be enabled.

Parameters
[in] | target_directory | Directory containing the target configuration files
[in] | log_level | The minimum displayed log level
[in] | log_file | Name of the log file
[in] | progress_callback | Pointer to the progress callback function
[in] | power_cycle_callback | Pointer to the power cycle callback function
Returns
DLDResult_t
Remarks
  • The log level can be used to filter out log messages with lower severity.
  • Progress reporting can be disabled by passing a null pointer (NULL) for parameter progress_callback.
DLDResult_t DOWNLOAD_API DLD_Init_Custom | ( | const char *const | target_directory,
 |  | uint32_t | log_level,
 |  | DLDLogCB_t | log_callback,
 |  | DLDProgressCB_t | progress_callback,
 |  | DLDPowerCycleCB_t | power_cycle_callback
 | ) |  |

Initializes the DLD Download Library.

This function initializes the DLD Download Library. All log messages are repoted via the specified log callback function. By passing a valid pointer to a progress callback function, progress reporting can be enabled.

Parameters
[in] | target_directory | Directory containing the target configuration files
[in] | log_level | The minimum displayed log level
[in] | log_callback | Pointer to the log callback function
[in] | progress_callback | Pointer to the progress callback function
[in] | power_cycle_callback | Pointer to the power cycle callback function
Returns
DLDResult_t
Remarks
  • The log level can be used to filter out log messages with lower severity.
  • The log mechanism can be disabled by passing a null pointer (NULL) for parameter log_callback.
  • Progress reporting can be disabled by passing a null pointer (NULL) for parameter progress_callback.
DLDResult_t DOWNLOAD_API DLD_Parse_Arguments | ( | const char **const | arguments,
 |  | uint32_t | size
 | ) |  |

Parses an array of arguments.

This function parses an array of arguments and performs the provided operation(s).

Parameters
[in] | arguments | Array of arguments
[in] | size | Size of the argument array
Returns
DLDResult_t
DLDResult_t DOWNLOAD_API DLD_Read_EEPROM | ( | uint16_t | node,
 |  | uint32_t | eeprom_address,
 |  | uint32_t | length,
 |  | uint8_t *const | data
 | ) |  |

Reads data from EEPROM of a connected node.

This function reads data from EEPROM of a connected node.

Parameters
[in] | node | Index of the node
[in] | eeprom_address | Start address
[in] | length | Number of bytes to be read
[out] | data | Data buffer that shall receive the read bytes
Returns
DLDResult_t
DLDResult_t DOWNLOAD_API DLD_Read_Flash | ( | uint16_t | node,
 |  | uint32_t | flash_address,
 |  | uint32_t | length,
 |  | uint8_t *const | data
 | ) |  |

Reads data from flash memory of a connected node.

This function reads data from flash memory of a connected node.

Parameters
[in] | node | Index of the node
[in] | flash_address | Start address
[in] | length | Number of bytes to be read
[out] | data | Data buffer that shall receive the read bytes
Returns
DLDResult_t
DLDResult_t DOWNLOAD_API DLD_Set_APDB | ( | uint16_t | node,
 |  | const char *const | application,
 |  | const DLDAPDB_t *const | apdb
 | ) |  |

Sets an APDB of a connected node.

This function sets an APDB of a connected node.

Parameters
[in] | node | Index of the node
[in] | application | Name of the application
[in] | apdb | Pointer to the APDB structure containing the data
Returns
DLDResult_t
DLDResult_t DOWNLOAD_API DLD_Set_Log_Level ( uint32_t log_level )

Sets the log level of the active log channel.

This function sets the log level to the active log channel (file or log callback).

Parameters
[in] log_level The minimum displayed log level
Returns
DLDResult_t
DLDResult_t DOWNLOAD_API DLD_Set_Node_Password | ( | uint16_t | node,
 |  | const char *const | password
 | ) |  |

Sets the password of a connected node.

This function sets the password of a connected node.

Parameters
[in] | node | Index of the node
[in] | password | The node's password
Returns
DLDResult_t
DLDResult_t DOWNLOAD_API DLD_Write_EEPROM | ( | uint16_t | node,
 |  | uint32_t | eeprom_address,
 |  | uint32_t | length,
 |  | const uint8_t *const | data
 | ) |  |

Writes data to the EEPROM of a connected node.

This function writes data to the EEPROM of a connected node.

Parameters
[in] | node | Index of the node
[in] | eeprom_address | Start address
[in] | length | Number of bytes to be written
[in] | data | Buffer containing the data
Returns
DLDResult_t
DLDResult_t DOWNLOAD_API DLD_Write_Flash | ( | uint16_t | node,
 |  | uint32_t | flash_address,
 |  | uint32_t | length,
 |  | const uint8_t *const | data
 | ) |  |

Writes data to the flash memory of a connected node.

This function writes data to the flash memory of a connected node.

Parameters
[in] | node | Index of the node
[in] | flash_address | Start address
[in] | length | Number of bytes to be written
[in] | data | Buffer containing the data
Returns
DLDResult_t
DLDResult_t DOWNLOAD_API DLD_Write_Log | ( | uint32_t | log_level,
 |  | const char *const | message
 | ) |  |

Writes a log message to the active log channel.

This function writes a log message to the active log channel (file or log callback).

Parameters
[in] | log_level | The log message's severity
[in] | message | The log message
Returns
DLDResult_t


TTCDownloadLibrary: FIDB.h File Reference

  • File List
  • Globals
  • release
  • inc
Data Structures | Macros | Typedefs
FIDB.h File Reference

FPGA IP Descriptor Block (FIDB) More...

#include "APDB.h"
#include "AuthenticationBlock.h"
Include dependency graph for FIDB.h:
This graph shows which files directly or indirectly include this file:

Data Structures

struct FIDB_t
FIDB structure. More...

Macros

#define | FIDB_VERSION 0x00000100UL
#define | FIDB_AUTH_OFFSET 88U

Typedefs

typedef struct FIDB_t FIDB_T
FIDB structure. More...

Detailed Description

FPGA IP Descriptor Block (FIDB)

Contains the definition for the FPGA IP descriptor block.

The FPGA IP descriptor block contains information about the FPGA IP. Note that the FPGA IP descriptor block cannot be modified.

Macro Definition Documentation

#define FIDB_AUTH_OFFSET 88U

The authentication block's offset in bytes.

#define FIDB_VERSION 0x00000100UL

Current FIDB version is version 1.0.

Typedef Documentation

typedef struct FIDB_t FIDB_T

FIDB structure.

Data structure for accessing the Bootloader Descriptor Block.


TTCDownloadLibrary: ptypes_apdb.h File Reference

  • File List
  • Globals
  • release
  • inc
Macros | Typedefs
ptypes_apdb.h File Reference

APDB target abstraction. More...

#include <cstdint>
Include dependency graph for ptypes_apdb.h:
This graph shows which files directly or indirectly include this file:

Macros

#define | UBYTE4_MAX_VALUE ((ubyte4)0xFFFFFFFFU)
maximum value of the ubyte4 type
#define | UBYTE4_MIN_VALUE ((ubyte4)0x00000000U)
minimum value of the ubyte4 type
#define | UBYTE2_MAX_VALUE ((ubyte2)0xFFFFU)
maximum value of the ubyte2 type
#define | UBYTE2_MIN_VALUE ((ubyte2)0x0000U)
minimum value of the ubyte2 type
#define | UBYTE1_MAX_VALUE ((ubyte1)0xFFU)
maximum value of the ubyte1 type
#define | UBYTE1_MIN_VALUE ((ubyte1)0x00U)
minimum value of the ubyte1 type

Typedefs

typedef uint8_t | ubyte1
unsigned 8bit integer
typedef uint16_t | ubyte2
unsigned 16bit integer
typedef uint32_t | ubyte4
unsigned 32bit integer
typedef uint64_t | ubyte8
unsigned 64bit integer
typedef int8_t | sbyte1
signed 8bit integer
typedef int16_t | sbyte2
signed 16bit integer
typedef int32_t | sbyte4
signed 32bit integer
typedef int64_t | sbyte8
signed 64bit integer

Detailed Description

APDB target abstraction.

This file defines the interface between the generic APDB format and the platform specific includes and definitions.


TTCDownloadLibrary: Globals

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Macros
  • a
  • b
  • d
  • f
  • s
  • u
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- a -

  • APDB_FLAGS_ABRD_ENABLE : APDB.h
  • APDB_FLAGS_CRC64_ENABLE : APDB.h
  • APDB_FLAGS_MULTI_APP : APDB.h
  • APDB_VERSION : APDB.h
  • AUTH_BLOCK_T : AuthenticationBlock.h
  • AUTH_SIZE : AuthenticationBlock.h
  • AUTH_VERSION : AuthenticationBlock.h


TTCDownloadLibrary: Globals

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Macros
  • a
  • b
  • d
  • f
  • s
  • u
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- b -

  • BL_APDB : APDB.h
  • BL_T_CAN_ID : APDB.h
  • BL_T_DATE : APDB.h
  • BLDB_AUTH_OFFSET : BLDB.h
  • BLDB_FLAG_RESERVED_0 : AuthenticationBlock.h
  • BLDB_FLAG_RESERVED_1 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_10 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_11 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_12 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_13 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_14 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_15 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_16 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_17 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_18 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_19 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_2 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_20 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_21 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_22 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_23 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_24 : BLDB.h , AuthenticationBlock.h
  • BLDB_FLAG_RESERVED_25 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_26 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_27 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_28 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_29 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_3 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_30 : BLDB.h , AuthenticationBlock.h
  • BLDB_FLAG_RESERVED_31 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_4 : BLDB.h , AuthenticationBlock.h
  • BLDB_FLAG_RESERVED_5 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_6 : BLDB.h , AuthenticationBlock.h
  • BLDB_FLAG_RESERVED_7 : BLDB.h , AuthenticationBlock.h
  • BLDB_FLAG_RESERVED_8 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_9 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_TYPE : BLDB.h
  • BLDB_T : BLDB.h
  • BLDB_VERSION : BLDB.h


TTCDownloadLibrary: Globals

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Macros
  • a
  • b
  • d
  • f
  • s
  • u
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- d -

  • DLD_ACTION_AUTHENTICATING : Download.hpp
  • DLD_ACTION_CONNECTING : Download.hpp
  • DLD_ACTION_DOWNLOADING_2ND : Download.hpp
  • DLD_ACTION_ERASING : Download.hpp
  • DLD_ACTION_FINALIZING_SECTORS : Download.hpp
  • DLD_ACTION_IDENTIFYING : Download.hpp
  • DLD_ACTION_NONE : Download.hpp
  • DLD_ACTION_READING : Download.hpp
  • DLD_ACTION_RETRIEVING_NODE_INFO : Download.hpp
  • DLD_ACTION_WRITING : Download.hpp
  • DLD_BIG_ENDIAN : Download.hpp
  • DLD_CAN_BAUD_RATE_100K : Download.hpp
  • DLD_CAN_BAUD_RATE_10K : Download.hpp
  • DLD_CAN_BAUD_RATE_125K : Download.hpp
  • DLD_CAN_BAUD_RATE_1M : Download.hpp
  • DLD_CAN_BAUD_RATE_20K : Download.hpp
  • DLD_CAN_BAUD_RATE_250K : Download.hpp
  • DLD_CAN_BAUD_RATE_33K : Download.hpp
  • DLD_CAN_BAUD_RATE_47K : Download.hpp
  • DLD_CAN_BAUD_RATE_500K : Download.hpp
  • DLD_CAN_BAUD_RATE_50K : Download.hpp
  • DLD_CAN_BAUD_RATE_5K : Download.hpp
  • DLD_CAN_BAUD_RATE_800K : Download.hpp
  • DLD_CAN_BAUD_RATE_83K : Download.hpp
  • DLD_CAN_BAUD_RATE_95K : Download.hpp
  • DLD_CAN_CHANNEL_0 : Download.hpp
  • DLD_CAN_CHANNEL_1 : Download.hpp
  • DLD_CAN_CHANNEL_2 : Download.hpp
  • DLD_CAN_CHANNEL_3 : Download.hpp
  • DLD_CAN_CHANNEL_4 : Download.hpp
  • DLD_CAN_CHANNEL_5 : Download.hpp
  • DLD_CAN_CHANNEL_6 : Download.hpp
  • DLD_CAN_CHANNEL_7 : Download.hpp
  • DLD_CAN_DRIVER_CANPRO_USB : Download.hpp
  • DLD_CAN_DRIVER_PCAN_PCI : Download.hpp
  • DLD_CAN_DRIVER_PCAN_USB : Download.hpp
  • DLD_CAN_ID_EXTENDED : Download.hpp
  • DLD_CAN_ID_STANDARD : Download.hpp
  • DLD_Connect() : Download.hpp
  • DLD_Deinit() : Download.hpp
  • DLD_Disconnect() : Download.hpp
  • DLD_Download_EEPROM_File() : Download.hpp
  • DLD_Download_Flash_File() : Download.hpp
  • DLD_Driver_Deinit() : Download.hpp
  • DLD_Driver_Deregister_All() : Download.hpp
  • DLD_Driver_Init() : Download.hpp
  • DLD_Driver_Register_CAN() : Download.hpp
  • DLD_Driver_Register_Custom_CAN() : Download.hpp
  • DLD_Driver_Register_Custom_UDP() : Download.hpp
  • DLD_Driver_Register_UDP() : Download.hpp
  • DLD_DRIVER_TYPE_CAN : Download.hpp
  • DLD_DRIVER_TYPE_UDP : Download.hpp
  • DLD_Erase_EEPROM() : Download.hpp
  • DLD_Erase_Flash() : Download.hpp
  • DLD_Get_APDB() : Download.hpp
  • DLD_Get_BLDB() : Download.hpp
  • DLD_Get_FIDB() : Download.hpp
  • DLD_Get_Memory_Info() : Download.hpp
  • DLD_Get_Node_Info() : Download.hpp
  • DLD_Get_Target_Info() : Download.hpp
  • DLD_Get_Version() : Download.hpp
  • DLD_Init() : Download.hpp
  • DLD_Init_Custom() : Download.hpp
  • DLD_ITEM_APDB : Download.hpp
  • DLD_ITEM_APPLICATION : Download.hpp
  • DLD_ITEM_BLDB : Download.hpp
  • DLD_ITEM_BOOTLOADER : Download.hpp
  • DLD_ITEM_CODESYS : Download.hpp
  • DLD_ITEM_CONFIGURATION_DATA : Download.hpp
  • DLD_ITEM_CRC_TABLE : Download.hpp
  • DLD_ITEM_EXTERNAL_EEPROM : Download.hpp
  • DLD_ITEM_EXTERNAL_FLASH : Download.hpp
  • DLD_ITEM_FIDB : Download.hpp
  • DLD_ITEM_FPGA_IP_CORE : Download.hpp
  • DLD_ITEM_INTERNAL_EEPROM : Download.hpp
  • DLD_ITEM_INTERNAL_FLASH : Download.hpp
  • DLD_ITEM_PDB : Download.hpp
  • DLD_ITEM_SECOND_STAGE : Download.hpp
  • DLD_ITEM_SECOND_STAGE_BLDB : Download.hpp
  • DLD_ITEM_SECOND_STAGE_BUFFER : Download.hpp
  • DLD_LITTLE_ENDIAN : Download.hpp
  • DLD_LOG_LEVEL_DEBUG : Download.hpp
  • DLD_LOG_LEVEL_ERROR : Download.hpp
  • DLD_LOG_LEVEL_INFO : Download.hpp
  • DLD_LOG_LEVEL_WARNING : Download.hpp
  • DLD_MAX_STRING_LENGTH : Download.hpp
  • DLD_Parse_Arguments() : Download.hpp
  • DLD_Read_EEPROM() : Download.hpp
  • DLD_Read_Flash() : Download.hpp
  • DLD_RESULT_ACCESS_DENIED : Download.hpp
  • DLD_RESULT_FILE_NOT_FOUND : Download.hpp
  • DLD_RESULT_INVALID_FILE : Download.hpp
  • DLD_RESULT_INVALID_FORMAT : Download.hpp
  • DLD_RESULT_INVALID_HW_ID : Download.hpp
  • DLD_RESULT_INVALID_OPERATION : Download.hpp
  • DLD_RESULT_INVALID_PARAMETER : Download.hpp
  • DLD_RESULT_INVALID_SIGNATURE : Download.hpp
  • DLD_RESULT_OK : Download.hpp
  • DLD_RESULT_OPERATION_FAILED : Download.hpp
  • DLD_Set_APDB() : Download.hpp
  • DLD_Set_Log_Level() : Download.hpp
  • DLD_Set_Node_Password() : Download.hpp
  • DLD_Write_EEPROM() : Download.hpp
  • DLD_Write_Flash() : Download.hpp
  • DLD_Write_Log() : Download.hpp
  • DLDCustomData_t : Download.hpp
  • DLDDriverCANReadCB_t : Download.hpp
  • DLDDriverCANWriteCB_t : Download.hpp
  • DLDDriverDeinitCB_t : Download.hpp
  • DLDDriverInitCB_t : Download.hpp
  • DLDDriverUDPReadCB_t : Download.hpp
  • DLDDriverUDPWriteCB_t : Download.hpp
  • DLDLogCB_t : Download.hpp
  • DLDPowerCycleCB_t : Download.hpp
  • DLDProgressCB_t : Download.hpp
  • DLDResult_t : Download.hpp


TTCDownloadLibrary: Globals

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Macros
  • a
  • b
  • d
  • f
  • s
  • u
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- f -

  • FIDB_AUTH_OFFSET : FIDB.h
  • FIDB_T : FIDB.h
  • FIDB_VERSION : FIDB.h


TTCDownloadLibrary: Globals

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Macros
  • a
  • b
  • d
  • f
  • s
  • u
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- s -

  • sbyte1 : ptypes_apdb.h
  • sbyte2 : ptypes_apdb.h
  • sbyte4 : ptypes_apdb.h
  • sbyte8 : ptypes_apdb.h


TTCDownloadLibrary: Globals

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Macros
  • a
  • b
  • d
  • f
  • s
  • u
Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- u -

  • ubyte1 : ptypes_apdb.h
  • UBYTE1_MAX_VALUE : ptypes_apdb.h
  • UBYTE1_MIN_VALUE : ptypes_apdb.h
  • ubyte2 : ptypes_apdb.h
  • UBYTE2_MAX_VALUE : ptypes_apdb.h
  • UBYTE2_MIN_VALUE : ptypes_apdb.h
  • ubyte4 : ptypes_apdb.h
  • UBYTE4_MAX_VALUE : ptypes_apdb.h
  • UBYTE4_MIN_VALUE : ptypes_apdb.h
  • ubyte8 : ptypes_apdb.h


TTCDownloadLibrary: Globals

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Macros
  • d

- d -

  • DLD_Connect() : Download.hpp
  • DLD_Deinit() : Download.hpp
  • DLD_Disconnect() : Download.hpp
  • DLD_Download_EEPROM_File() : Download.hpp
  • DLD_Download_Flash_File() : Download.hpp
  • DLD_Driver_Deinit() : Download.hpp
  • DLD_Driver_Deregister_All() : Download.hpp
  • DLD_Driver_Init() : Download.hpp
  • DLD_Driver_Register_CAN() : Download.hpp
  • DLD_Driver_Register_Custom_CAN() : Download.hpp
  • DLD_Driver_Register_Custom_UDP() : Download.hpp
  • DLD_Driver_Register_UDP() : Download.hpp
  • DLD_Erase_EEPROM() : Download.hpp
  • DLD_Erase_Flash() : Download.hpp
  • DLD_Get_APDB() : Download.hpp
  • DLD_Get_BLDB() : Download.hpp
  • DLD_Get_FIDB() : Download.hpp
  • DLD_Get_Memory_Info() : Download.hpp
  • DLD_Get_Node_Info() : Download.hpp
  • DLD_Get_Target_Info() : Download.hpp
  • DLD_Get_Version() : Download.hpp
  • DLD_Init() : Download.hpp
  • DLD_Init_Custom() : Download.hpp
  • DLD_Parse_Arguments() : Download.hpp
  • DLD_Read_EEPROM() : Download.hpp
  • DLD_Read_Flash() : Download.hpp
  • DLD_Set_APDB() : Download.hpp
  • DLD_Set_Log_Level() : Download.hpp
  • DLD_Set_Node_Password() : Download.hpp
  • DLD_Write_EEPROM() : Download.hpp
  • DLD_Write_Flash() : Download.hpp
  • DLD_Write_Log() : Download.hpp


TTCDownloadLibrary: Globals

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Macros
  • AUTH_BLOCK_T : AuthenticationBlock.h
  • BL_APDB : APDB.h
  • BL_T_CAN_ID : APDB.h
  • BL_T_DATE : APDB.h
  • BLDB_T : BLDB.h
  • DLDCustomData_t : Download.hpp
  • DLDDriverCANReadCB_t : Download.hpp
  • DLDDriverCANWriteCB_t : Download.hpp
  • DLDDriverDeinitCB_t : Download.hpp
  • DLDDriverInitCB_t : Download.hpp
  • DLDDriverUDPReadCB_t : Download.hpp
  • DLDDriverUDPWriteCB_t : Download.hpp
  • DLDLogCB_t : Download.hpp
  • DLDPowerCycleCB_t : Download.hpp
  • DLDProgressCB_t : Download.hpp
  • DLDResult_t : Download.hpp
  • FIDB_T : FIDB.h
  • sbyte1 : ptypes_apdb.h
  • sbyte2 : ptypes_apdb.h
  • sbyte4 : ptypes_apdb.h
  • sbyte8 : ptypes_apdb.h
  • ubyte1 : ptypes_apdb.h
  • ubyte2 : ptypes_apdb.h
  • ubyte4 : ptypes_apdb.h
  • ubyte8 : ptypes_apdb.h


TTCDownloadLibrary: Globals

  • File List
  • Globals
  • All
  • Functions
  • Typedefs
  • Macros
  • a
  • b
  • d
  • f
  • u

- a -

  • APDB_FLAGS_ABRD_ENABLE : APDB.h
  • APDB_FLAGS_CRC64_ENABLE : APDB.h
  • APDB_FLAGS_MULTI_APP : APDB.h
  • APDB_VERSION : APDB.h
  • AUTH_SIZE : AuthenticationBlock.h
  • AUTH_VERSION : AuthenticationBlock.h

- b -

  • BLDB_AUTH_OFFSET : BLDB.h
  • BLDB_FLAG_RESERVED_0 : AuthenticationBlock.h
  • BLDB_FLAG_RESERVED_1 : BLDB.h , AuthenticationBlock.h
  • BLDB_FLAG_RESERVED_10 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_11 : BLDB.h , AuthenticationBlock.h
  • BLDB_FLAG_RESERVED_12 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_13 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_14 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_15 : BLDB.h , AuthenticationBlock.h
  • BLDB_FLAG_RESERVED_16 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_17 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_18 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_19 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_2 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_20 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_21 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_22 : BLDB.h , AuthenticationBlock.h
  • BLDB_FLAG_RESERVED_23 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_24 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_25 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_26 : BLDB.h , AuthenticationBlock.h
  • BLDB_FLAG_RESERVED_27 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_28 : BLDB.h , AuthenticationBlock.h
  • BLDB_FLAG_RESERVED_29 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_3 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_30 : BLDB.h , AuthenticationBlock.h
  • BLDB_FLAG_RESERVED_31 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_4 : BLDB.h , AuthenticationBlock.h
  • BLDB_FLAG_RESERVED_5 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_6 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_7 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_8 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_RESERVED_9 : AuthenticationBlock.h , BLDB.h
  • BLDB_FLAG_TYPE : BLDB.h
  • BLDB_VERSION : BLDB.h

- d -

  • DLD_ACTION_AUTHENTICATING : Download.hpp
  • DLD_ACTION_CONNECTING : Download.hpp
  • DLD_ACTION_DOWNLOADING_2ND : Download.hpp
  • DLD_ACTION_ERASING : Download.hpp
  • DLD_ACTION_FINALIZING_SECTORS : Download.hpp
  • DLD_ACTION_IDENTIFYING : Download.hpp
  • DLD_ACTION_NONE : Download.hpp
  • DLD_ACTION_READING : Download.hpp
  • DLD_ACTION_RETRIEVING_NODE_INFO : Download.hpp
  • DLD_ACTION_WRITING : Download.hpp
  • DLD_BIG_ENDIAN : Download.hpp
  • DLD_CAN_BAUD_RATE_100K : Download.hpp
  • DLD_CAN_BAUD_RATE_10K : Download.hpp
  • DLD_CAN_BAUD_RATE_125K : Download.hpp
  • DLD_CAN_BAUD_RATE_1M : Download.hpp
  • DLD_CAN_BAUD_RATE_20K : Download.hpp
  • DLD_CAN_BAUD_RATE_250K : Download.hpp
  • DLD_CAN_BAUD_RATE_33K : Download.hpp
  • DLD_CAN_BAUD_RATE_47K : Download.hpp
  • DLD_CAN_BAUD_RATE_500K : Download.hpp
  • DLD_CAN_BAUD_RATE_50K : Download.hpp
  • DLD_CAN_BAUD_RATE_5K : Download.hpp
  • DLD_CAN_BAUD_RATE_800K : Download.hpp
  • DLD_CAN_BAUD_RATE_83K : Download.hpp
  • DLD_CAN_BAUD_RATE_95K : Download.hpp
  • DLD_CAN_CHANNEL_0 : Download.hpp
  • DLD_CAN_CHANNEL_1 : Download.hpp
  • DLD_CAN_CHANNEL_2 : Download.hpp
  • DLD_CAN_CHANNEL_3 : Download.hpp
  • DLD_CAN_CHANNEL_4 : Download.hpp
  • DLD_CAN_CHANNEL_5 : Download.hpp
  • DLD_CAN_CHANNEL_6 : Download.hpp
  • DLD_CAN_CHANNEL_7 : Download.hpp
  • DLD_CAN_DRIVER_CANPRO_USB : Download.hpp
  • DLD_CAN_DRIVER_PCAN_PCI : Download.hpp
  • DLD_CAN_DRIVER_PCAN_USB : Download.hpp
  • DLD_CAN_ID_EXTENDED : Download.hpp
  • DLD_CAN_ID_STANDARD : Download.hpp
  • DLD_DRIVER_TYPE_CAN : Download.hpp
  • DLD_DRIVER_TYPE_UDP : Download.hpp
  • DLD_ITEM_APDB : Download.hpp
  • DLD_ITEM_APPLICATION : Download.hpp
  • DLD_ITEM_BLDB : Download.hpp
  • DLD_ITEM_BOOTLOADER : Download.hpp
  • DLD_ITEM_CODESYS : Download.hpp
  • DLD_ITEM_CONFIGURATION_DATA : Download.hpp
  • DLD_ITEM_CRC_TABLE : Download.hpp
  • DLD_ITEM_EXTERNAL_EEPROM : Download.hpp
  • DLD_ITEM_EXTERNAL_FLASH : Download.hpp
  • DLD_ITEM_FIDB : Download.hpp
  • DLD_ITEM_FPGA_IP_CORE : Download.hpp
  • DLD_ITEM_INTERNAL_EEPROM : Download.hpp
  • DLD_ITEM_INTERNAL_FLASH : Download.hpp
  • DLD_ITEM_PDB : Download.hpp
  • DLD_ITEM_SECOND_STAGE : Download.hpp
  • DLD_ITEM_SECOND_STAGE_BLDB : Download.hpp
  • DLD_ITEM_SECOND_STAGE_BUFFER : Download.hpp
  • DLD_LITTLE_ENDIAN : Download.hpp
  • DLD_LOG_LEVEL_DEBUG : Download.hpp
  • DLD_LOG_LEVEL_ERROR : Download.hpp
  • DLD_LOG_LEVEL_INFO : Download.hpp
  • DLD_LOG_LEVEL_WARNING : Download.hpp
  • DLD_MAX_STRING_LENGTH : Download.hpp
  • DLD_RESULT_ACCESS_DENIED : Download.hpp
  • DLD_RESULT_FILE_NOT_FOUND : Download.hpp
  • DLD_RESULT_INVALID_FILE : Download.hpp
  • DLD_RESULT_INVALID_FORMAT : Download.hpp
  • DLD_RESULT_INVALID_HW_ID : Download.hpp
  • DLD_RESULT_INVALID_OPERATION : Download.hpp
  • DLD_RESULT_INVALID_PARAMETER : Download.hpp
  • DLD_RESULT_INVALID_SIGNATURE : Download.hpp
  • DLD_RESULT_OK : Download.hpp
  • DLD_RESULT_OPERATION_FAILED : Download.hpp

- f -

  • FIDB_AUTH_OFFSET : FIDB.h
  • FIDB_VERSION : FIDB.h

- u -

  • UBYTE1_MAX_VALUE : ptypes_apdb.h
  • UBYTE1_MIN_VALUE : ptypes_apdb.h
  • UBYTE2_MAX_VALUE : ptypes_apdb.h
  • UBYTE2_MIN_VALUE : ptypes_apdb.h
  • UBYTE4_MAX_VALUE : ptypes_apdb.h
  • UBYTE4_MIN_VALUE : ptypes_apdb.h


TTCDownloadLibrary: inc Directory Reference

  • release
  • inc
inc Directory Reference
Directory dependency graph for inc:

Files

file | APDB.h
The Application Descriptor Block (APDB)
file | AuthenticationBlock.h
Authentication Block.
file | BLDB.h
Bootloader Descriptor Block (BLDB)
file | Download.hpp
Download Library API.
file | FIDB.h
FPGA IP Descriptor Block (FIDB)
file | ptypes_apdb.h
APDB target abstraction.


TTCDownloadLibrary: release Directory Reference

  • release
release Directory Reference
Directory dependency graph for release:

Directories

directory inc


TTCDownloadLibrary: Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };
/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };
/* Class not documented with doxygen comments */
class Undocumented { };
/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };
/*! A template class */
template<class T> class Templ { };
/*! Class that is inherited using protected inheritance */
class ProtectedBase { };
/*! Class that is inherited using private inheritance */
class PrivateBase { };
/*! Class that is used by the Inherited class */
class Used { };
/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
protected ProtectedBase,
private PrivateBase,
public Undocumented,
public Templ<int>
{
private:
Used *m_usedClass;
};

This will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled gray box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.

The arrows have the following meaning:

  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.